Show only assigned IPs

Started by befuddled

Show only assigned IPs   28 March 2015, 04:06

Pulled this down today to look for an IP I didn't recognize (found it easily by the way).

First time it scanned, it only took a few seconds and showed only the assigned IPs.

Went into settings, ticked a few options and on rescan, it took much longer and pulled and displayed every IP in the range (.0 to .254), most of which are empty. I though it was the Display Dead Devices, but apparently not. I want to see anything/everything with an IP assigned with as much information as possible about each one, but not the rest.

Rather than start all over removing them one at a time and rescanning, which might be doing it?

Always Analyze Device
Show Last Scan Time
Determine Packet Loss and Jitter
Resolve Host Names
Resolve MAC Addresses
Grab HTTP and FTP server banner
Scan for shared resources
Determine Disk Space
Enumerate Folders
Display (H or V) Grid Lines

Or one or more of the below:

SoftPerfect support forum
Attachments:
open | download – NetScanSnip.JPG (32.2 KB)
SoftPerfect Support forum - Andrew avatar image

Re: Show only assigned IPs   28 March 2015, 11:59

This usually happens because the app sends both ICMP and ARP requests and if either succeeds, assumes the IP address is alive. In some networks the ARP method only succeeds on the second run and then those responses would be from the default gateway. I am not sure why exactly this happens.

To fix this you can try:

Turn off the ARP scan (set to ICMP only)

or

Prior to the scan wipe the ARP cache by typing arp -d * at a command prompt.

Re: Show only assigned IPs   28 March 2015, 22:03

Neither of those changed anything.

I dumped everything, set the IP range to about 10 addresses and started scanning with only a few items ticked each time.

It seems like the 'Always analyze' may have done it. Without that checked I got only active IPs with all of the selected columns populated. Then reset the range to the full .0 - .255, scanned again and it still worked within a minute or so. Hangs up briefly on devices like the Roku box and IP cameras when trying to pull the OS and workgroup names that don't really exist.
SoftPerfect Support forum - Andrew avatar image

Re: Show only assigned IPs   28 March 2015, 22:28

In that case, yes it's Always Analyse Device. The difference with Display Dead Devices is if neither ICMP nor ARP ping have succeeded, then
  • Always Analyse Device: the app still attempts to run all other scans on the target IP address and adds it into the list.
  • Display Dead Devices: the app does not attempt to run all other scans on the target IP address and adds it into the list.

Re: Show only assigned IPs   29 March 2015, 00:32

No problem. Works fine. Can't complain considering the price. laugh

Sometimes you can get the answer faster if you try the forum search and/or have a look at the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • If possible, check your spelling and grammar.

Author:

Email:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

 ********  **         **     **  **     **  **    ** 
 **    **  **    **   **     **  **     **   **  **  
     **    **    **   **     **  **     **    ****   
    **     **    **   *********  **     **     **    
   **      *********  **     **  **     **     **    
   **            **   **     **  **     **     **    
   **            **   **     **   *******      **    

Message: