No new column appears when adding a WMI query

Started by Aaron

Aaron

No new column appears when adding a WMI query   05 February 2017, 01:17

I've got a bit of a bug that appears every now and then. If I've got a results file already populated with multiple WMI query results, then go in and add a new WMI query, every so often when I add one, a new column for it won't appear, despite it being selected. If I go to the 'Visible Columns' dialog window, it doesn't appear as an option either.

If however, I reorder the WMI queries, and move the newly created entry above an existing (and visible) one, the column name appears with the previously-positioned columns results, and the previously visible column heading now disappears... for example (in which I only have built-in "options" selected, and custom WMI queries)...

SoftPerfect support forum

All columns are selected to be visible in the 'Visible Colums' dialog - however if I open the WMI selection window, there are two additional queries at the bottom that are missing columns (both valid queries, both don't show in the 'Visible Columns' screen either)...

SoftPerfect support forum

If I move the two missing entries from the bottom to above some existing columns...

SoftPerfect support forum

The column headings adjust on the results screen (but the existing remain where they are, instead of moving with the heading), with the two newer column headings now visible, but now the two WMI queries that are at the bottom of the list are missing...

SoftPerfect support forum

The only way I've been able to get this to work once columns start disappearing is to blow away the current config and create it all from scratch again sad Any ideas on this one?
SoftPerfect Support forum - Andrew avatar image

Re: No new column appears when adding a WMI query   05 February 2017, 11:45

It's merely a limitation of the Network Scanner's internal design. Columns are pre-created on startup and by default only 10 of each type are created (e.g. 10 x WMI, 10 x Remote Registry, etc).

This can be changed by launching the app with the /maxcols:20 or /maxcols:30 command line switch. It can be made permanent by specifying this parameter in a shortcut. The downside of this is slower startup time and higher memory usage.

I guess we'll take a look to see whether it can re-designed or otherwise improved.
Aaron

Re: No new column appears when adding a WMI query   05 February 2017, 12:16

Thanks for the quick reply - makes sense! Don't need to worry about it too much - the /maxcols command does the trick smile

Re: No new column appears when adding a WMI query   06 February 2017, 16:14

This happens to me all the time. I run NetScan from several shares I sometimes I forget the columns. Could you just add the MAXCOLS value in the GUI in Options? -WS
SoftPerfect Support forum - Andrew avatar image

Re: No new column appears when adding a WMI query   06 February 2017, 17:15

Sorry, it can't be done easily - the columns are pre-created even before a config is loaded. I may be able to increase the default maximum number though. Would 20 columns of each type suffice?
Aaron

Re: No new column appears when adding a WMI query   07 February 2017, 03:09

Twenty would work for me smile

Re: No new column appears when adding a WMI query   07 February 2017, 16:33

Yes 20 is good, may we ask of 30 as the default? Thanks -WS

Sometimes you can get the answer faster if you try the forum search and/or have a look at the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • If possible, check your spelling and grammar.

Author:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

 ********   **     **  **     **  **     **  **     ** 
 **     **  **     **  ***   ***  ***   ***  ***   *** 
 **     **  **     **  **** ****  **** ****  **** **** 
 ********   **     **  ** *** **  ** *** **  ** *** ** 
 **     **  **     **  **     **  **     **  **     ** 
 **     **  **     **  **     **  **     **  **     ** 
 ********    *******   **     **  **     **  **     ** 

Message: