Duplicate IP addresses and 0.0.0.0 subnet mask

Started by Jason

Jason

Duplicate IP addresses and 0.0.0.0 subnet mask   06 December 2018, 14:25

The Duplicate IP Addresses feature always displays 0.0.0.0 for the subnet mask. Please see the picture below.
I am using a DLink DUB-E100 USB 2 Ethernet adapter. The function itself works in the software, but displays wrong. My subnet is 255.255.255.0 (see picture).

We are running WinPCap v4.1.3.
Windows 7 Enterprise SP1, Network Scanner v7.1.6

SoftPerfect support forum
SoftPerfect Support forum - Ann avatar image
Ann

Re: Duplicate IP addresses and 0.0.0.0 subnet mask   06 December 2018, 14:45

We have seen a similar behaviour with Win10Pcap. It looks like for some adapters (or in some circumstances) the WinPCap library doesn't return the network mask. Instead it returns an empty string, which is the 0.0.0.0 that you see.

The Network Scanner has an in-build workaround: if it is unable to get the netmask, it uses the default value of 255.255.255.0. That's why it works, though the display is incorrect. To be sure, we have retested it in a clean Windows 7 installation with WinPCap 4.1.3 and it worked as expected, which you can see in the screen shot below:

SoftPerfect support forum
Jason

Re: Duplicate IP addresses and 0.0.0.0 subnet mask   07 December 2018, 11:49

Our IM department sends this installation as a package to my machine. Netscan and WinpCap are automatically installed. What I found regarding the subnet mask being 0.0.0.0 in the duplicate IP address detection was that I had Win10pCap already installed prior to the package installation. So I guess maybe those two packages were conflicting if they were both installed. After uninstalling Win10pCap, the issue of the 0.0.0.0 subnet is gone.

I had done some further testing with only Win10pCap installed, and the issue came back, so it appears be a Win10pCap issue.

I also tried the new NpCap (per the update on WinpCap website) configured for WinpCap compatibility mode (selected at installation), but that did not work. The adapter list was blank. No message from the software WinpCap wasn't installed.

Thanks for your support,
Jason
SoftPerfect Support forum - Andrew avatar image

Re: Duplicate IP addresses and 0.0.0.0 subnet mask   10 December 2018, 14:40

It is unfortunately unclear why the list was blank when using Npcap in WinPCap compatibility mode. Nonetheless we've just updated the Network Scanner so it can use Npcap directly, without the compatibility layer. Here is a screen shot of Npcap on Windows 7 x64 without WinPCap compatibility enabled:

SoftPerfect support forum

The preliminary build can be downloaded here.

Reply to this topic

Sometimes you can get the answer faster if you try the forum search and/or have a look at the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • If possible, check your spelling and grammar.

Author:

Email:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

 ********  ********  **    **  **     **        ** 
 **           **      **  **   **     **        ** 
 **           **       ****    **     **        ** 
 ******       **        **     **     **        ** 
 **           **        **      **   **   **    ** 
 **           **        **       ** **    **    ** 
 ********     **        **        ***      ******  

Message: