Error C000009A

Started by Carlos

Carlos

Error C000009A   24 November 2012, 05:56

I get this error trying to mount a Ram disk under Windows .
Any clue to handle the problem?

Thanks in advance for your help.

Carlos
VD

Error C000009A   24 November 2012, 07:33

What is your operating system version?
Carlos

Error C000009A   24 November 2012, 18:20

Windows 7 SP1
Super Speed Ram Disk Plus works well.
VD

Error C000009A   24 November 2012, 19:36

32-bit or 64-bit version?
Carlos

Error C000009A   26 November 2012, 17:00

32-bit
VD

Error C000009A   26 November 2012, 17:12

For 32 bit, this is a known issue.
Bruce Williams

Error C000009A   05 December 2012, 03:45

I keep getting this error code when I add a disk. I am running Windows 7 32 bit.

Error C000009A

Bruce
bimbo

Error C000009A   07 January 2013, 15:19

I get Error C000009A if the sum of the sizes of the 3 ramdisks that I create is larger than 616 MB.
1st 256MB, 2nd 256MB, 3rd 104MB. Cannot create 3rd ramdrive with size >=105 MB get Error C000009A.
Apart this limitation the program runs beautifully.
Win XP SP3, 3GB RAM

Error C000009A   22 January 2013, 09:37

I think I was getting the same error with my 10752MB RAMdisk.

I wonder if it's related to the Free RAM reported in Task Manager, as I got the error and was unable to mount the RAMdisk when Available RAM was plenty (13-14GB) but Free RAM was lower, maybe 6GB or less? Then I mounted a 10GB RAMdisk OK in IMGDisk and after dismounting it, Free RAM was much higher, around 13-14GB. I then tried mounting the SP RAMdisk again and it worked OK.

I'll try and get the exact error code next time it happens.

Running Win7 x64 Ultimate SP1 with 16GB RAM

Error C000009A   24 January 2013, 02:34

Yeah, it's the same error "One or more volumes could not be mounted. Operation failed with status code = C000009A and image status code = Image load succeeded". Well no, it didn't succeed!
laton

Error C000009A   03 February 2013, 04:24

xp sp3 32bit.. 4GB Ram..

when i mount ramdisk lager than 325MB.. Error C000009A occurs.
King Daddy

Error C000009A   01 April 2013, 13:57

Windows XP SP3, 3 GB RAM, Not sensitibe to file system or raw; or other options. It seems to have a size limit issue. Disk/Add 300 MB works, 360 and larger gets subject error code, and "Unknown reason".
alllala

Error C000009A   15 April 2013, 17:49

I get the Error C000009A too, when I´m trying to create a bigger Ramdisk (tested up to 250MB that worked).

I have Win7 SP1 x64 with 32GB of Ram.

RamDisk never worked right for me though. Even on the other machine I get trouble with it.
JT

Re: Error C000009A   15 October 2013, 17:49

I've only tried to mount a small disk (150 MB), but still get this error in Vista SP2.
hmp_goose

Re: Error C000009A   20 February 2014, 15:35

"Operation failed with status code C000009A and image status code = Unknown reason
"0 the operation completed succesfully"

First time user, switching over from someone elses' RAMDisk; Made a few 8MB disks by mistake, then I got this when I asked for 8GB
SoftPerfect Support forum - Andrew avatar image

Re: Error C000009A   20 February 2014, 15:41

On what system (Windows version and bitness) are you receiving this message and how much RAM have you got?
hmp_goose

Re: Error C000009A   21 February 2014, 07:05

Oh: Right.

It's a Win7-64 box, with 24GB in triple channel (i7-990X); It would come up if asked for a drive of 2049 or lager. 2048 worked perfectly, creating and deleting at will, which is what the documentation led me to believe was normal behavior.

But it's probably a moot point: While I've gotten a couple of errors like that, and a few "unable to dismount" to go along with it, it seems all I had to do was reboot, and the drive (and memory usage) I was expecting where there!
4EverMaAT

Re: Error C000009A   22 February 2014, 12:42

I am also getting this error. Win 7, 64 bit SP1. acer laptop i5 3230M, 12GB RAM (1 8gb + 1 4gb stick). Pagefile = 1024MB.

SoftPerfect support forum


I use another program called PrimoCache and whenever I try to create a L1 ram cache larger than 2048 MB, I get an error that there is insufficient memory available. I would love for you to do a remote session or give us an ability to send you a log of something. Is there some kind of debug mode where we can generate a log of the program performance?

I have no clue if it is the pagefile, windows telling SoftPerfect that there is less ram that is really available?
SoftPerfect Support forum - Andrew avatar image

Re: Error C000009A   23 February 2014, 01:21

It appears there's something not quite right with the system. If both PrimoCache and the RAM Disk fail to allocate more than 2 GB, then it's apparently a system-wide issue.

Please post here a screen shot of the System Information\Memory from Process Explorer or at least Performance/Memory from the Task Manager.

I also recommend to increase the pagefile's size to the amount equal to the installed RAM's size to see if this fixes the issue.
4EverMaAT

Re: Error C000009A   23 February 2014, 18:28

Quote

hmp_goose

But it's probably a moot point: While I've gotten a couple of errors like that, and a few "unable to dismount" to go along with it, it seems all I had to do was reboot, and the drive (and memory usage) I was expecting where there!


The same thing with me. After I rebooted, the 6gb ram disk drive was available for use. Not sure what that was all about, because if the memory is available, the program is supposed to just create the drive off the bat.
SoftPerfect Support forum - Andrew avatar image

Re: Error C000009A   23 February 2014, 23:45

It's not that simple. It has to be 6 GB of continuous memory (not fragmented) which is the case after reboot.

After a while RAM becomes fragmented and the system may not be able to allocate a continuous block that is large enough to hold the entire RAM disk.
hmp_goose

Re: Error C000009A   24 February 2014, 18:40

Allow me to fallow up on this: Having gotten used to the idea one must simply reboot should they see this error, I preceded to do so, and received a BSoD 0x1E.

OK: I'd gotten that once before from this app; I tried editing a disk, after using the "move the temp directory" tool (love that!), and with no page file on it, I grew a 4GB up to 6, and it blew up 0x1E right then and there.

The 6GB disk I wanted was there, waiting for me, after the reboot.

A pretty good problem to have, all things considered …

smile
SoftPerfect Support forum - Andrew avatar image

Re: Error C000009A   24 February 2014, 18:55

Unfortunately there isn't much we can do without a memory dump. If possible, could you please do the following?
  1. Enable the kernel memory dump (a minidump is not sufficient):
  2. Restart the system. Then once a crash occurs, please send me the MEMORY.DMP file (compress it and upload to a file sharing service)
hmp_goose

Re: Error C000009A   10 March 2014, 16:00

Via BlueScreenView [onedrive.live.com]
VD

Re: Error C000009A   10 March 2014, 23:47

BlueScreenView won't be of much help. SoftPerfect needs to analyze your kernel memory dump files from C:\Windows\memory.dmp.
S_ua

Re: Error C000009A   10 June 2014, 19:08

Hi all, I am also getting this error.
My PC:
Microsoft Windows 7 Service Pack 1 x64
HexaCore AMD Phenom II X6 1045T, 3376 MHz (16 x 211)
MSI 760GA-P43/FX (MS-7699)
32768 MB (4xDDR3-1333 DDR3 SDRAM)
AMD Radeon HD 7700 Series (1 Gb)

I want to create a disc 21 Gb size and I get Error C000009A.
Empirically calculated without error I can create ram disk up to 2300 MB. When I add a disk larger than 2300 Mb, I get the message: Error C000009A.

Then I tried to create a disk size of 21 GB in the program Passmark OSFMount. Disk created successfully.
SoftPerfect RamDisk is wonderful program, but that is where the error occurred. If you need I can give remote desktop to my PC. e.g. via teamviewer.

Re: Error C000009A   17 August 2016, 09:10

Hello there,

I am aware of the age of this thread, but am posting here because I have the *exact* same issue. I have 16gb of ram, and need to make a 4gb ramdisk in Windows 7 64-bit. This worked for me for over a month with SoftPerfect RamDisk, but now when I try and create/mount the disk, I get the same error as everyone else in this thread.

Does SoftPerfect still support this software now, given that it's free? This support topic has been open for many years and has no resolution...

Thanks!
SoftPerfect Support forum - Andrew avatar image

Re: Error C000009A   17 August 2016, 10:30

We do support the product, but I am afraid we've been unable to reproduce this issue ever. Error C000009A means insufficient system resources, which typically indicates an out-of-memory condition. It's not necessarily low memory, for example, a similar error would occur if there was no continuous 4 GB block of RAM due to memory fragmentation.

I would recommend to increase the size of pagefile to give the system more resources or decrease the size of the RAM Disk. Perhaps also consider what other software you have installed recently that may have caused resources shortage.
Across various machines running Windows 8 and above I have come across an issue when I can only mount a volume or disk under basic emulation or at most flagged as a removable drive. However if I flag the drive for Hard Disk Emulation (Slower) and attempt to mount the drive regardless of an image being used or clean slate an error occurs and the disk does not mount and an error code is presented on my screen. What I have discovered while watching the mounting process through Windows 10 is a SAN Policy conflict: when mounting begins the disk remains in an offline state.

My solution, which I have now done to all of my machines and has resolved the issue:
- Run an elevated command and load into DISKPART.
- Change the SAN policy by typing the following: SAN POLICY=OnlineAll
Nothing else, just mount the disk. I wish you all the best of luck and if I have failed you I am sorry but we are all only human.

Re: Fix for mounting an emulated hard disk on Win 8 and above   01 November 2017, 15:49

@nodnarb

I checked the current SAN policy on my Windows 7 Pro SP1 x64 machine I was having problem with this error on previously, and it is defaulted to OnlineAll already, with no change needed there. (checked by entering DISKPART and simply typing in SAN).

I reinstalled Softperfect Ramdisk and the same issue occurs as before (see attached screenshot), on a fresh reboot of my machine and with a pagefile that is 2x the size of my 16gb of ram, with both the pagefile and OS on a fast commercial-grade SSD.

I really don't know why this program worked perfectly before and then decided to start screwing up along the way. I really liked this ramdisk software more than any others, but it seems that some windows update or setting breaks it, unfortunately.

If anyone ever discovers a fix to this issue, I'll stay subscribed to this thread. I suppose that's the only hope I have at this point. I'm going to uninstall the software now, with the hopes this is one day fixed.

Thanks for the suggestions.
Attachments:
open | download – 2017-10-31 23_48_12-SoftPerfect RAM Disk.jpg (26 KB)

Sometimes you can get the answer faster if you try the forum search and/or have a look at the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • If possible, check your spelling and grammar.

Author:

Email:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

 ********  **    **  ********    *******    *******  
    **     **   **   **     **  **     **  **     ** 
    **     **  **    **     **  **     **  **     ** 
    **     *****     **     **   ********   ******** 
    **     **  **    **     **         **         ** 
    **     **   **   **     **  **     **  **     ** 
    **     **    **  ********    *******    *******  

Message: