Disk not emptied on Windows 8.1 shutdown

Started by André Willik Valenti

André Willik Valenti

Disk not emptied on Windows 8.1 shutdown   04 November 2014, 04:11

Hello,

I've been enjoying SP RAMDisk for some months now. My ram disk is used to store temp stuff and I'd like it to be emptied when I shutdown or restart the computer. However, on Windows 8.1, this only happens if I restart the computer.

If I shut it down, when I turn it on, every file and folder is back to the ram disk. This means they were stored on my SSD during shutdown. This is exactly what I want to avoid: unnecessary writes to my SSD.

It's an NTFS, boot-time, removable disk. I tried changing to NTFS32 and non-removable, without success. Any ideas?

Thank you!
André
SoftPerfect Support forum - Andrew avatar image

Re: Disk not emptied on Windows 8.1 shutdown   04 November 2014, 10:42

This is because Windows 8 features a so-called hybrid boot. Even when you shutdown the computer, it is not a real shutdown and Windows preserves the RAM disk's contents.

You may want to either disable hybrid boot or do a full shutdown.
André Willik Valenti

Re: Disk not emptied on Windows 8.1 shutdown   04 November 2014, 23:56

Thanks for your quick answer and for the alternatives!

I thought that would be the reason, indeed. But shouldn't Windows eject removable media before shutting down? Or else, could I run a command from command line to unmount the ram disk before shutting down?
SoftPerfect Support forum - Andrew avatar image

Re: Disk not emptied on Windows 8.1 shutdown   05 November 2014, 00:07

You could just use a logon-time RAM disk rather than a boot-time RAM disk. This type of disk will be mounted upon log-on and unmounted upon log-off or shutdown, which may be exactly what you want.
André Willik Valenti

Re: Disk not emptied on Windows 8.1 shutdown   28 November 2014, 01:33

Thanks again for your answer. I tried that, but strangely RAMDisk appears to be no longer starting with Windows. It's configured to do so (even task manager says it does start with Windows) and it does create boot-time ram disks. However, it only creates logon-time ram disks if I start it manually. Any ideas?
SoftPerfect Support forum - Andrew avatar image

Re: Disk not emptied on Windows 8.1 shutdown   28 November 2014, 15:16

Check this setting in the RAM Disk global setting, perhaps it's unticked?

SoftPerfect support forum
André Willik Valenti

Re: Disk not emptied on Windows 8.1 shutdown   29 November 2014, 00:11

Nope, it's actually checked...
SoftPerfect Support forum - Andrew avatar image

Re: Disk not emptied on Windows 8.1 shutdown   02 December 2014, 09:58

Sorry in that case I have no idea. It could be some antivirus software issue I guess.

You can try deleting the existing autorun entry in the registry and create a new one manually (or create a shortcut in the Startup folder).
Humanoid1

Re: Disk not emptied on Windows 8.1 shutdown   16 August 2015, 22:45

Well thank you very much for your answer Andrew!

I really appreciate this solution as this issue have been annoying me for ages now (since starting to use your RAM Disk and trialling Windows 10) !

During initial setup I'd specified an img file on a secondary HDD and later canceled the img. Even going as far as deleting all RAMDisks and restarting from scratch and still seemed to have the lengthy 16GB RAMDisk being saved despite there being no file in the originally specified location. I'd edged towards the conclusion somehow the setting have been half cleaned and ended up defaulting to an alternate location on the C: SSD...

I would imagine it is well worth adding this tip to your help pages about creating backup image files. I'm sure this will help alleviate confusion with many people that do not yet know about Hybrid Boot on Windows 10 or even 8.


Leading up to finding this thread I must say I am very impressed with the speed of effective official responses to the many threads here. A lot of companies would do well to emulate such excellent caring service.

Thanks.
K

Re: Disk not emptied on Windows 8.1 shutdown   14 October 2015, 19:50

This problem was caused by WINDOWS 8.1 fast boot.

Disable fast boot and everything will be ok!!

Reply to this topic

Sometimes you can get the answer faster if you try the forum search and/or have a look at the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • If possible, check your spelling and grammar.

Author:

Email:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

 **    **  ********  **     **  **     **  ********  
  **  **   **        **     **  **     **  **     ** 
   ****    **        **     **  **     **  **     ** 
    **     ******    *********  **     **  ********  
    **     **        **     **  **     **  **        
    **     **        **     **  **     **  **        
    **     ********  **     **   *******   **        

Message: