Delay at shutdown when "Save Contents to Image" is enabled

Started by Vanfear

I have 2048Mb NTFS RAM disk with "Save Contents to Image" option enabled. With this option PC shutdown time increased by 10-18 seconds instead of the usual ~5 seconds. The disk uses only 100Mb in RAM and saves it to SSD. Same happens with with exFAT. Is there a reason for such delay?
SoftPerfect Support forum - Ann avatar image

Re: Delay at shutdown when "Save Contents to Image" is enabled   03 April 2019, 11:22

This may be due to a Windows feature called 'hybrid boot'. When you shut down a hybrid boot system, this feature saves the current system state to the hard disk before switching off. On boot, it restores the system state back into memory. This process adds a delay on top of saving and loading the RAM Disk image.

We recommend disabling the hybrid boot permanently, which can be done in either of the two ways:
  • Open an elevated command prompt and type
    REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Power" /V HiberbootEnabled /T REG_DWORD /D 0 /F
    Then reboot.
  • Alternatively, if you don't hibernate your PC and want to save a few GBs of disk space, you can disable hibernation. This will permanently deactivate the hybrid boot as well. For that, in an elevated command prompt type
    powercfg /h off

Reply to this topic

Sometimes you can find a solution faster if you try the forum search, have a look at the knowledge base, or check the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • Write in English. If possible, check your spelling and grammar.




A brief and informative title for your message, approximately 4–8 words:


Spam prevention: please enter the following code in the input field below.

 ********  **     **  **     **  ********   ********  
 **        ***   ***  ***   ***  **     **  **     ** 
 **        **** ****  **** ****  **     **  **     ** 
 ******    ** *** **  ** *** **  ********   ********  
 **        **     **  **     **  **         **        
 **        **     **  **     **  **         **        
 **        **     **  **     **  **         **