E-mail alerts

Started by laurent

laurent

E-mail alerts   05 December 2012, 00:22

Great software, thanks a lot. Monitoring home network made simple this is great. One great addition will be a mail alert when a new device is detected on the network ( just a mail sent through SMTP with the device IP, mac address and name ).
SoftPerfect Support forum - Andrew avatar image

Re: E-mail alerts   05 December 2012, 08:42

Thank you, will add this soon! Stay tuned smile

Re: E-mail alerts   07 December 2012, 19:54

Email alert is a great idea. +1

It would be based on an UNKNOWN mac coming online. Obviously, we don't want email spam as laptops and printers get turned on/off etc.
Dusan

Configuring Gmail e-mail alerts   04 March 2014, 20:09

how configure my mail (gmail) when unknown devices are detected ?

I get a message E mail sending failed

SoftPerfect support forum
SoftPerfect Support forum - Andrew avatar image

Re: Configuring Gmail e-mail alerts   05 March 2014, 00:31

Gmail only provides SSL-secured SNMP service, which isn't currently supported.

Use your ISP's SMTP server that should allow unencrypted sessions on port 25.

Re: Configuring Gmail e-mail alerts   25 July 2014, 07:04

Hi. I tried setting this up with outlook.com smtp server with the same result as gmail. What email smtps are supported? I would like to use this feature.

Thanks
Hector
SoftPerfect Support forum - Andrew avatar image

Re: Configuring Gmail e-mail alerts   25 July 2014, 11:48

For Gmail, you need to install OpenSSL and then configure it to use a secure connection.

Re: Configuring Gmail e-mail alerts   25 July 2014, 13:43

Thanks!!
seb

Re: E-mail alerts   20 December 2014, 21:58

Hi,

I don't understand what to write in the four fields. Who can help me ?

Thanks
SoftPerfect Support forum - Andrew avatar image

Re: E-mail alerts   20 December 2014, 22:38

Re: E-mail alerts   26 December 2014, 23:37

Google accepts connections on port 587. It could be useful to add a field for the port number (25 by default).
SoftPerfect Support forum - Andrew avatar image

Re: E-mail alerts   27 December 2014, 00:48

Just place it after the host name separated by a colon, e.g. smtp.gmail.com:587
staki

Re: E-mail alerts   04 February 2015, 02:05

Hi !

I am now under Fedora 21, and I have installed WiFiGuard. Everything works flawlessly except the mail alerts.
I have OpenSSL installed, and I have tried the trick of putting ":587" after the Outlook's SMTP address in the mail alert configuration box in WiFiGuard, but it still doesn't work.
What could be wrong?
SoftPerfect Support forum - Andrew avatar image

Re: E-mail alerts   04 February 2015, 13:05

What have you chosen under the Connection drop-down list? Please post a screen shot.

SoftPerfect support forum
staki

Re: E-mail alerts   05 February 2015, 02:42

Hi Andrew !

The connection drop-down list is grayed out so I can't change anything. It shows the regular option.
SoftPerfect Support forum - Andrew avatar image

Re: E-mail alerts   05 February 2015, 11:28

This could be because WiFi Guard was not able to find OpenSSL. It looks for libssl.so and libcrypto.so, not version specific.

On my test Ubuntu installation it was fixed either by installing openssl-dev or making a couple of symbolic links:
sudo ln -s libssl.so.1.0.0 libssl.so
sudo ln -s libcrypto.so.1.0.0 libcrypto.so
Hope this helps.
staki

Re: E-mail alerts   05 February 2015, 13:47

I installed openssl-devel, and now the connection drop-down list isn't grayed out any more. But it still doesn't work, whatever I choose for option, wifiguard hangs when I try to make a mail test,and I have to kill and restart it.
staki

Re: E-mail alerts   05 February 2015, 13:54

The options are : "Regular", "Secure to regular port (STARTTLS)", and "Secure to dedicated port (TLS)". None of them work
SoftPerfect Support forum - Andrew avatar image

Re: E-mail alerts   05 February 2015, 15:04

I don't know in this case, sorry. Probably you are using incorrect e-mail parameters? It works for me for gmail on Fedora 21

SoftPerfect support forum
staki

Re: E-mail alerts   05 February 2015, 17:14

Now it works !!
I was trying with ":587" and it failed, but with ":465" it works.

Many many thanks for the help !

Sometimes you can get the answer faster if you try the forum search and/or have a look at the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • If possible, check your spelling and grammar.

Author:

Email:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

 **      **  **     **  ********  **     **  **     ** 
 **  **  **  ***   ***     **     **     **  ***   *** 
 **  **  **  **** ****     **     **     **  **** **** 
 **  **  **  ** *** **     **     **     **  ** *** ** 
 **  **  **  **     **     **      **   **   **     ** 
 **  **  **  **     **     **       ** **    **     ** 
  ***  ***   **     **     **        ***     **     ** 

Message: