service shutting down shortly after launch

Started by Szafran

Szafran

service shutting down shortly after launch   06 December 2005, 13:14

Hi

I have a problem with the service. It's installed on WinXP SP2 with all available updates and after the system starts the service also starts, but for only about 10sec and then dies. The only thing that helps is to get to the Services MMC and launching it manually.

Any1 please help.

Greets
Szafran
SoftPerfect Support forum - Andrew avatar image

Re: service shutting down shortly after launch   07 December 2005, 00:28

Is there any messages in the system event log (see both Application and System logs), is there a file BWMSVC.LOG located in the bandwidth manager installation directory? The reason should be logged somewhere.
Szafran

Re: service shutting down shortly after launch   09 December 2005, 08:36

App log:
THelper thread exception: Unable to set a multimedia timer

Sys log says something about event start timeout (the message is in polish so if i would copy/paste it here i don't think it would help)
SoftPerfect Support forum - Andrew avatar image

Re: service shutting down shortly after launch   09 December 2005, 09:19

This message means the manger was unable to initialize the timer. Unfortunately, the only solution is to try another (clean) copy of Windows or other PC as the bandwidth manager host.
Szafran

Re: service shutting down shortly after launch   09 December 2005, 22:14

this is a clean copy of windows, trying another computer is not an option. before i've installed the system from scratch it was working ok on the same config. that is really weird.
Szafran

Re: service shutting down shortly after launch   09 December 2005, 23:16

also i've setup the service to run again after a minute after an error (first, second and further error also) but this didn't help either. but manual start works every time.
SoftPerfect Support forum - Andrew avatar image

Re: service shutting down shortly after launch   10 December 2005, 03:08

How do you start it manually, through the Services CP applet or with 'net start ...' command?
Szafran

Re: service shutting down shortly after launch   10 December 2005, 04:26

services applet
SoftPerfect Support forum - Andrew avatar image

Re: service shutting down shortly after launch   10 December 2005, 05:29

We have just built a debug release. In the event of a multimedia timer failure, it'll write a error code into the BWMSVC.LOG. Please download it here [URL expired], install over the previous installation and reboot. Then take a look at the BWMSVC.LOG what is there?
Szafran

Re: service shutting down shortly after launch   10 December 2005, 11:24

i've downloaded it, but i'll install it tomorrow now gotta get some sleep before yesterday 14h out (classes - gotta get some higher ed)
Szafran

Re: service shutting down shortly after launch   11 December 2005, 03:24

i've tried this version, but it's all the same - only manual starting of the service works, and also no log is created.

but this time just at the end of the install i've got an error message saying that the service failed to start because of time out.
SoftPerfect Support forum - Andrew avatar image

Re: service shutting down shortly after launch   11 December 2005, 03:42

But the previous copy wrote a message about a multmedia timer failure. Does the new build write it?
Szafran

Re: service shutting down shortly after launch   11 December 2005, 04:16

yes thosse messages are also in the app/sys logs

i've found now a new error description there. it says that the time limit for a service to start (30000ms) was exceeded.

is there any way for me to change this to for eg 60000ms ??
SoftPerfect Support forum - Andrew avatar image

Re: service shutting down shortly after launch   11 December 2005, 04:35

The messages regarding the multumedia timer now have detailed error code. What are the codes returned after the error? Changing the startup timeout has no sense as the service must start in less than 10 seconds.
Szafran

Re: service shutting down shortly after launch   11 December 2005, 05:44

but i can try it... maybe it'll help

and now i'll copy all the info from the erors:
app:

err1: THelper thread exception: Unable to set a multimedia timer

err2: Nie mo¿na znaleŸæ opisu dla identyfikatora zdarzenia ( 0 ) w Ÿródle ( bwmsvc.exe ). Byæ mo¿e komputer lokalny nie ma wymaganych informacji rejestru lub plików DLL potrzebnych do wyœwietlania komunikatów z komputera zdalnego. Mo¿esz u¿yæ flagi /AUXSOURCE= do pobrania tego opisu; wiêcej informacji mo¿na znaleŸæ w Pomocy i obs³udze technicznej. Nastêpuj¹ce informacje s¹ czêœci¹ zdarzenia: Proces us³ugi nie móg³ po³¹czyæ siê z kontrolerem us³ugi.

this one says that it can't find the id of the error

and the err3 says the same as err2

sys:

err1: Nie mo¿na uruchomiæ us³ugi SoftPerfect Bandwidth Manager z powodu nastêpuj¹cego b³êdu:
Us³uga nie odpowiada na sygna³ uruchomienia lub sygna³ steruj¹cy w oczekiwanym czasie.
Aby znaleŸæ wiêcej informacji, zobacz [go.microsoft.com] w Centrum pomocy i obs³ugi technicznej.

this one says about the timeout

err2: Nie mo¿na uruchomiæ us³ugi SoftPerfect Bandwidth Manager z powodu nastêpuj¹cego b³êdu:
Us³uga nie odpowiada na sygna³ uruchomienia lub sygna³ steruj¹cy w oczekiwanym czasie.
Aby znaleŸæ wiêcej informacji, zobacz [go.microsoft.com] w Centrum pomocy i obs³ugi technicznej.

this one also says about the timeout
SoftPerfect Support forum - Andrew avatar image

Re: service shutting down shortly after launch   11 December 2005, 06:15

Try to open the Services applet, choose the bandwidth manager service and set the option 'Allow service to interact with desktop'. Then reboot. Perhaps, a error message appears after restart.
Szafran

Re: service shutting down shortly after launch   11 December 2005, 07:50

no visible effect :/

if u know how can i change the timeout then please tell me... i'll try that

Sometimes you can get the answer faster if you try the forum search and/or have a look at the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • If possible, check your spelling and grammar.

Author:

Email:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

 ********  **     **  **     **  **     **  **     ** 
    **     ***   ***  **     **  ***   ***  **     ** 
    **     **** ****  **     **  **** ****  **     ** 
    **     ** *** **  *********  ** *** **  ********* 
    **     **     **  **     **  **     **  **     ** 
    **     **     **  **     **  **     **  **     ** 
    **     **     **  **     **  **     **  **     ** 

Message: