problem with 2 nics + 1 server

Started by Wes

Wes

problem with 2 nics + 1 server   19 January 2006, 19:16

I have 1 server with 2 nics installed. It is running server 2003+rras. 1 nic is connected to the broadband router and the other is connected to a switch. I plan to connect several computers to the switch and control the bandwidth from the server. At this point I cannot get it to work.

1. I bridged the 2 nics together. They are listed in the ethernet bridges window.

2. Created a test rule with 5k/sec both directions, TCP/UDP, applied the rule to wan interface(the nic connected to the broadband router)
Source address is my local IP range (192.168.1.25-192.168.1.50)
Destination address is set to any address.

After refreshing the stats and setting the rule to the other nic interface, still no change, stats are zero.

What am I doing wrong?
SoftPerfect Support forum - Andrew avatar image

Re: problem with 2 nics + 1 server   19 January 2006, 19:26

You have specified wrong interface. Apply the rule on the LAN interface (connected to the switch) and this will work.
SoftPerfect Support forum - Andrew avatar image

Re: problem with 2 nics + 1 server   19 January 2006, 19:31

Sorry, I have read your message uncarefully. Does your network look like this (correct me if I am wrong)?

PC1 .. PCn with the addresses 192.168.1.25 to 192.168.1.50 are connected through the switch to the LAN nic of the server running the bandwidth manager. The second nic of server is connected to the broadband router.

Is the Internet available from the PC1 .. PCn when you bridge the NICs?
Wes

Re: problem with 2 nics + 1 server   19 January 2006, 19:40

Well, before bridging the NICs with the software, I have enabled Routing and Remote Access on the server to forward requests to the internet. After bridging them with the program made no difference.
SoftPerfect Support forum - Andrew avatar image

Re: problem with 2 nics + 1 server   19 January 2006, 21:28

If you have enabled the RRAS service and the server does NAT (Newtwork Address Translation), there is no sense to use bridging. Remove the bridge and make a rule like this:

Rule #1:
Protocol: TCP/UDP
Direction: Both
Rate: set as needed
Source: 192.168.1.25 - 192.168.1.50
Destination: Any IP address
Interface: LAN (one, which points to the local network)

This should work.

Sometimes you can get the answer faster if you try the forum search and/or have a look at the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • If possible, check your spelling and grammar.

Author:

Email:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

  ******   **    **  **     **  **    **  **     ** 
 **    **   **  **   ***   ***  **   **    **   **  
 **          ****    **** ****  **  **      ** **   
 **           **     ** *** **  *****        ***    
 **           **     **     **  **  **      ** **   
 **    **     **     **     **  **   **    **   **  
  ******      **     **     **  **    **  **     ** 

Message: