Clients seen as one hose through Linksys router

Started by Paul Burkhaulter

Paul Burkhaulter

Clients seen as one hose through Linksys router   10 November 2008, 20:59

Alright I know i'm asking alot here because I know whats causing the problem and don't exactly need a solution as much as suggestions...

My network

Satellite modem---->XP desktop with ICS----->linksys wireless router---->clients

Test rule 1:
Direction: Both
Transfer rate 1/kb
Source: 192.168.1.200
Destination: Any, Any
protocol both
Int: LAN

This rule has NO effect, I'm assuming the router is doing some kind of NAT and SBM is not seeing the clients IP address(or MAC when using mac as source)

test rule 2:
direction: both
transfer rate 1/kb
source: local host
destination: any, any
protocol: both
Int: LAN

Now this rule seems to work but i'm guessing it will limit all traffic coming from the router to 1/KB instead of giving each client 1/kb(1/kb is just testing, i'm wanting to limit all clients to 16-20kb)

I'm not 100% positive about this though but seems logical, SBM is seeing the router as local host and anything going through it will be limited by the rule.

So any help would be awesome, linksys WRT54G doesnt seem to have a feature to disable NAT. There might be something on DD-WRT but i'm trying to stay factory firmware. PLEASE HELP!!
SoftPerfect Support forum - Andrew avatar image

Clients seen as one hose through Linksys router   10 November 2008, 22:09

According to the Linksys user guide, it can be changed on the Routing screen, you can set the routing mode of the Router, rather than Gateway. In this case, this should disable NAT and let SBM see the computers behind the router.

You are right about the second rule, which you mentioned, it limits all communications between the XP desktop and the router as a set rate, while you'd like to set a specific limit for each client. Try switching the router into the 'Routing' mode instead of 'Gateway' to see if it helps.
Paul Burkhaulter

Clients seen as one hose through Linksys router   11 November 2008, 02:14

Andrew thanks for the help. I believe you are right but I've tried switching it to "Router" BUT it seems to break it. You got me too take a 2nd look, after changing the operating mode to "router" the WRT54G still receives an IP on status page but does not allow any connected computer to access the internet. Can you help? Do I need to set a few static routes?

Clients seen as one hose through Linksys router   11 November 2008, 11:45

Could you please describe just a little more about the IP address configuration.

For example:

IP address of the LAN side adaptor in the XP machine running ICS?

IP address of the WAN side adaptor in the XP machine (private or public address)?

IP address of the Interface on the Linksys that connects to the XP machine? and which interface are you using, a LAN port or WAN port to connect the linksys to the XP machine?

I take it the range the clients operate in is 192.168.1.X.

It'll be easier to suggest a routing setup with any answers to the above.

From past suggestions on other forums on routing with WRT54G's some users found the WAN port still blocks some incoming traffic on certain firmware even in router mode. If that were to cause a problem using a LAN port on the WRT54g to the XP machine would help. But the above needs to be answered first.

Cheers,
Gavin.

Clients seen as one hose through Linksys router   11 November 2008, 12:00

I switched to static routing to solve a similar problem as I have BWM between access points (long range wireless links) and clients.

You could always just take a cable from a LAN port of the WRT54G to the XP machine, and assign clients their default router as the ICS/BWM machine. That way you avoid using the WAN port and NAT on the WRT54G all together and use it more of just an access point?

If you must use the WAN port of the WRT54G to the XP machine, IP forwarding in XP needs to be turned on (in registry) and static IPs assigned on each router. Then some static routes.

This is just an example if my setup was similar to yours:

Windows XP machine ICS on LAN card 192.168.0.1
WRT54G in router mode WAN port IP address static 192.168.0.2
WRT54G LAN port IP address 192.168.1.1
WRT54G clients assigned address 192.168.1.2-254 etc...

The XP machine would need IP forwarding enabled via registry, and a static route added:

route add 192.168.1.0 mask 255.255.255.0 192.168.0.2

On the WRT54G WAN port setup the default gateway as 192.168.0.1 (no need to add a static route but router mode would need to be enabled).

Clients then use the WRT54G LAN IP address 192.168.1.1 as their default router.

Then BWM should be ready to see the clients IP addresses and the XP machine can talk back to the WRT54G to reach 192.168.1.X addresses via the WRT54G 192.168.0.2 WAN port on the unit.

For enabling IP forwarding this is a good guide:

Enabling IP Forwarding in various Windows platforms

Cheers,
Gavin.
SoftPerfect Support forum - Andrew avatar image

Clients seen as one hose through Linksys router   11 November 2008, 13:08

I am not sure what your current IP addressing is, but as I a guess, if before you have switched it to 'Router' the DNS and Default Gateway settings on the client computers were set to the IP address of the router, now you need to change client's DNS and Gateway to the IP address of the NIC in the XP ICS desktop (the one connected to the LAN).
Paul Burkhaulter

Clients seen as one hose through Linksys router   11 November 2008, 18:26

Gavin,

you are truly awesome and I am in debt to you forever. I only have one issue now...

DNS doesnt seem to be working, computers on the wireless network cannot access the internet using DNS names(www.google.com etc) BUT internet works fine if I type in googles IP address.

Any ideas? I followed exact instructions above, router wan port is running static IP(192.168.0.2) Do I need to set a static DNS IP also? If so what would it be? I tried a few but no luck. Thanks so much for help again....

Clients seen as one hose through Linksys router   11 November 2008, 18:51

Hi Paul.

Andrew pretty much remembered what I completely forgot wink

The clients will need to use the DNS address 192.168.0.1 (ICS encorperates DNS forwarding). This can either be put in manually on each client machine or if the clients are using DHCP; on the WRT54G in it's DHCP LAN/WIFI settings (not WAN) it needs to hand out the DNS server of 192.168.0.1 (again only if clients are using DHCP).

Alternatively you can just put your ISP's DNS server addresses in to the clients and skip ICS DNS forwarding all together. To find out what that is you can "ipconfnig /all" from the command line to find out the DNS server used over your satellite connection (on the XP WAN Interface).

Either way you should be on the way then smile

Regarding changing the default gateway on client machines, when using the WAN port to link the WRT54G to the XP machine, the clients will use the WRT54G LAN IP address as their default gateway. So it sounds like that's already correct if you can get google by IP.

Cheers,
Gavin.

Clients seen as one hose through Linksys router   11 November 2008, 18:55

I forgot to include:

The XP machine static route must be made permanent or it'll be lost after a reboot. To do this, you include the "-p" which I missed out earlier in my example.

route -p add 192.168.1.0 mask 255.255.255.0 192.168.0.2

Gavin.

Clients seen as one hose through Linksys router   11 November 2008, 18:57

Opps typo:

"ipconfnig /all" should be "ipconfig /all"

I'm a big fan of being able to edit posts on forums lol.
Paul Burkhaulter

Clients seen as one hose through Linksys router   11 November 2008, 23:20

Yeah I did know about the persistent command, the system is working 100% now. But I still have to test bandwidth limiting and such per user but should work with that nasty NAT gone.

Thanks to all of you for so much help, never got such a good response from a forum. Good people! Thanks again
SoftPerfect Support forum - Andrew avatar image

Clients seen as one hose through Linksys router   12 November 2008, 12:19

Quote

I'm a big fan of being able to edit posts on forums lol.


I have just made it editable. Indeed that was a real inconvenience! Thanks Gavin!
Peter Martin

Clients seen as one hose through Linksys router   17 January 2009, 17:38

I've had exactly the same problem except that I'm trying to use a reflashed DD_WRT router. There was a hint in one of the earlier replies that DD-WRT may not behave exactly the same " some users found the WAN port still blocks some incoming traffic on certain firmware ".

Did you mean DD_WRT?

The software looks very good but I'd like to see some better "getting started" documentation. For instance how hard would it be to supply some example rules which could be imported and and then edited or customised? I did manage to figure out how to do it, in the end, but a few examples would have saved me hours.

There must be a lot of customers who will have say an cable or ADSL connection connected into the WAN port of a wireless router. They'll use a desktop PC with an fixed connection to the router and use the wireless for laptops etc.

They'll install SBM on to their desktop PC, connect up to their router an like Paul B and myself they'll have problems!

If you need to get into the registry, as in " The XP machine would need IP forwarding enabled via registry, and a static route added: route add 192.168.1.0 mask 255.255.255.0 192.168.0.2 " it would seem reasonable to expect this to be documented somewhere without have to search through the help forums. It looks like I may need to upgrade to XP Pro to get IP forwarding to work.

Again that should be made much clearer in system requirements.

Reply to this topic

Sometimes you can find a solution faster if you try the forum search, have a look at the knowledge base, or check the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • Write in English. If possible, check your spelling and grammar.

Author:

Email:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

 **     **   ******   **        ********   ******  
  **   **   **    **  **        **        **    ** 
   ** **    **        **        **        **       
    ***     **        **        ******    **       
   ** **    **        **        **        **       
  **   **   **    **  **        **        **    ** 
 **     **   ******   ********  **         ******  

Message: