Setting up bridge on Windows 2000 workstation with 2 NICs

Started by Brian

I have a Windows 2000 workstation with 2 NICs. 1 NIC connects to the Internet through a T1. The 2nd NIC connects to a local network using 192.168.1.210. The machine connects to the Internet no problem, and I can ping the workstation from the local network. I installed Bandwidth Manager and enabled bridging between the two cards. I added a rule that allows all traffic to flow.

When I change the Default Gateway on an another machine to point to 192.168.1.210 I cannot access the Internet. I can ping 192.168.1.210. Can you help?
gaurav

Re: Setup Problem   25 February 2006, 17:19

Dear Brian

give complete network diagram with ips.
i think ur network will be like it.

Router --> Windows 2000 Workstation--> client
if yes. then i can give u a sample.
try this
Router(192.168.1.1) --> (192.168.1.2)Windows 2000 Workstation(192.168.1.210)--> client

now give any ip in the same range to client & 192.168.1.1 as a gateway. if u will use bridging.then ur server will remain invisible but u can filter & control traffic.

Thanks.
SoftPerfect Support forum - Andrew avatar image

Re: Setting up bridge on Windows 2000 workstation with 2 NICs   25 February 2006, 17:37

Does the station with two NICs route IP packets? Has it enabled the ICS (Internet Connection Sharing) service?

I am asking because there are specific sutations. Let me explain. When your network layout is like this

<Uplink/Router [A.A.A.A]> - <[B.B.B.B] Windows with Bandwidth Manager [C.C.C.C]> - <Switch> - <Client computers [D.D.D.D, E.E.E.E, etc]>

where A.A.A.A to E.E.E.E are IP addresses. The most imporant thing here is what is used a gateway on the client computers. If the clients' gateway was C.C.C.C this means that the Windows station routes traffic to the uplink and there is NO need to bridge the interfaces. However, if previously your clients had A.A.A.A as their gateway and you have just placed the Windows station between the uplink and clients, another scheme apply.

Please tell what is your situation and I'll be able to advise you further.
Brian

Re: Setup Problem   28 February 2006, 00:47

<router[172.22.0.1]> - <[172.22.0.2] Win2k with BM [192.168.1.210]> - <Switch> - <Client Computers [192.168.1.2-100]>

The BM computer does not have routing turned on, and ICS is not enabled. ICS cannot be used, I have a DHCP server on the network. The BM documentation is very limited, I am assuming the bridging took care of this.
SoftPerfect Support forum - Andrew avatar image

Re: Setup Problem   28 February 2006, 02:54

This does not work because bridging does not translate addresses. Bridge is just a packet forwarder. In general, you have two solutions: enable ICS on the Win2K server, or change the router internal address to 192.168.1.x. I'd recommend to reconfigure your network as follows:
<router[192.168.1.212]> - <[192.168.1.211] Win2k with BM [192.168.1.210]> - <Switch> - <Client Computers [192.168.1.2-100]>

In this case the default gateway on the clients must be 192.168.1.212. Interfaces 192.168.1.211 and 192.168.1.210 must be bridged by the bandwidth manager.
Brian

Re: Setup Problem   28 February 2006, 03:24

Will it not work using NAT?
SoftPerfect Support forum - Andrew avatar image

Re: Setup Problem   28 February 2006, 03:49

You can use NAT to keep existing addressing, or change 172.22.0.x to 192.168.1.x to avoid using NAT.

Sometimes you can get the answer faster if you try the forum search and/or have a look at the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • If possible, check your spelling and grammar.

Author:

Email:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

  *******   **     **  **     **  ********  **     ** 
 **     **   **   **   **     **  **        ***   *** 
 **           ** **    **     **  **        **** **** 
 ********      ***     **     **  ******    ** *** ** 
 **     **    ** **    **     **  **        **     ** 
 **     **   **   **   **     **  **        **     ** 
  *******   **     **   *******   **        **     ** 

Message: