Upload "chokes" my adsl connection

Started by Amit

Amit

Upload "chokes" my adsl connection   04 March 2006, 22:10

Hi,
Is there a way to use this software to solve this problem?
I configured a bridge with 2 nics one connected to a router and the other to a switch and limited the speed on all incoming traffic to the switch interface on the server. That DIDNT do the trick. I want that any lan host will be able to upload freely without hurting the connection's download. As I understood this has something to do with ACK packets not getting out properly or something like that.
So can it be done?
Thanks
SoftPerfect Support forum - Andrew avatar image

Re: Upload "chokes" my adsl connection   04 March 2006, 23:42

Yes, in this case you should set an upload limit a bit lower than the link bandwiedth. For example, if your router is connected to a 512 Kbps duplex link, you can limit all uploads say at 500 or 490 Kbps to give the rest to the ACK confirmations from parallel downloads.
Amit

Re: Upload "chokes" my adsl connection   05 March 2006, 02:35

Thanks for the reply.
I didnt see an option to refer to ACK confirmations.
Did you mean limiting the uploading ports like p2p networks?
Can you give a rule example that will explain what you meant?
SoftPerfect Support forum - Andrew avatar image

Re: Upload "chokes" my adsl connection   05 March 2006, 02:55

No, I mean limiting the whole upstream. Supposing that your network looks like <PC1 .. PCn> - <Switch> - <Bridge with bandwidth manager> - <Router/DSL>
Then I can suggest the following rule:

Protocol: TCP/UDP
Direction: Incoming
Rate: set as needed
Source: 192.168.0.1 - 192.168.0.255
Destination: Any IP address
Interface: LAN (one, which points to the local network)

As you can see with this rule we can limit the flow through the bridge (upload) at a specified rate a bit lower than the upstream bandwidth. Then, you need to enable the 'Transmit short ACK frames with no queue' option at the bandwidth manager options. Of course you also need to adjust the LAN IP range in the rule.

That's all and should work as expected. If you still have any questions, please ask.
Amit

Re: Upload "chokes" my adsl connection   05 March 2006, 05:43

Tested it with one lan host for now and it works fine, hope it will stay that way over time and when ill try to limit more hosts.
I've been looking for a solution to this problem for a long time.

Thanks again.
Amit

Re: Upload "chokes" my adsl connection   18 March 2006, 05:41

When I'm runnning a P2P application it uploads and still chockes the connection.

Configuration:

<PC1 .. PCn> - <Router> - <Bridge with bandwidth manager> - <ADSL Modem>

with rule:

Protocol: TCP/UDP
Direction: Incoming
Rate: tried 5-10KB
Source: 192.168.2.101 - 192.168.2.103
Destination: Any IP address
Interface: Router

Is there a way to let applications on any host to upload as much as they like and still limit them so that the upload wont affect the download?
SoftPerfect Support forum - Andrew avatar image

Re: Upload "chokes" my adsl connection   18 March 2006, 17:21

When you use P2P it usually opens lots of connections and these have to be delayed in the queue together with outgoing requests to download. What kind of downloads would you like to speed up (HTTP, FTP or same P2P)?
Amit

Re: Upload "chokes" my adsl connection   18 March 2006, 20:54

The only thing I would like to speed up is winamp shoutcast streaming. I dont care if it will lower P2P d/l rates.
Why isnt enabling 'Transmit short ACK frames with no queue' enough to do the trick?
SoftPerfect Support forum - Andrew avatar image

Re: Upload "chokes" my adsl connection   18 March 2006, 21:58

Please describe your situation in a whole. Is the shoutcast streaming incoming or outgoing? What are other network streams?
Amit

Re: Upload "chokes" my adsl connection   18 March 2006, 23:09

The shoutcast stream is incoming.
No other network streams.
gaurav

Re: Upload "chokes" my adsl connection   19 March 2006, 01:39

shoutcast stream server mainly use port 8000.
so open this port with unlimted bw.
& cap all other ports.
SoftPerfect Support forum - Andrew avatar image

Re: Upload "chokes" my adsl connection   19 March 2006, 01:57

Yes, I also think so. It is a good idea to limit uploads at a rate lower than the link bandwidth (i.e. if your modem upstream is 100 Kbps, make a limit of 80 kbps for uploads), enable the 'ACK with no queue' option and create two rules for incoming traffic: one 'Unlimited' for shoutcast stream and aother limited (say half of incoming link bandwidth) to throttle any downloads.
Amit

Re: Upload "chokes" my adsl connection   19 March 2006, 03:41

I'm sorry I dont understand,
You're suggesting throttling the download but the problem isnt that the d/l is at full capacity and that shoutcast streaming skips as a result of that.
The problem is that even if no one the the lan is d/l anything except for the shoutcast stream (even several streams are far from the download capacity but lats assume 1 for the matter) if someone on the lan is uploading at full capacity that 1 stream will skip.
I have already made a rule to throttle the upload to a little less than the link bandwidth and 'ACK with no queue' is already enabled.
Maybe I didnt understand what you meant, if you could give some rules examples it would be nice.
SoftPerfect Support forum - Andrew avatar image

Re: Upload "chokes" my adsl connection   19 March 2006, 16:41

You told "I have already made a rule to throttle the upload to a little less than the link bandwidth and 'ACK with no queue' is already enabled". That's enough if there are no other downloads. Does it work as expected? If no, try the following:

Protocol: TCP/UDP
Direction: Incoming
Rate: Unlimited
Source: 192.168.2.101 - 192.168.2.103
Destination: Any IP address : Port 80
Interface: Router

Protocol: TCP/UDP
Direction: Incoming
Rate: 5 KB
Source: 192.168.2.101 - 192.168.2.103
Destination: Any IP address
Interface: Router

Rememeber the rules order, it must be the same! As you can see the first rule permits anything in the shoutcast stream to go back to server as soon as possible while the second rule throttles other uploads.

Try it and let us know about the result.
gaurav garg

Re: Upload "chokes" my adsl connection   19 March 2006, 20:03

if above solution does not solve ur problem then their may be one more reason.

in our area some isp's are giving bandwidth in a way in which u can use your total bandwidth alloted to u on upload or download. may be same is in ur case that u are using ur total bandwidth in uploading then how will u download.

plz.. check it.
Amit

Re: Upload "chokes" my adsl connection   25 March 2006, 02:13

I tried the above suggestion, at first it seemed work but then I saw it didnt and I think its because the shoutcast server port is changed from server to server and on some servers it isnt 8000. So I found out the port number of the server I mainly use just to see if I will be able to watch that one server without skipping. That also didnt work.
Then I thought that the logic of limiting all and allowing just the shoutcast is wrong anyway because why should I limit all when whats causing the problem are P2P apps. So i found out the port number of one of the P2P apps i use (uTorrent) which is 5800 and limited only packets with source: 5800. That also didnt work.
It seems that nothing is being limited at all.
Anyway I'm clueless so any help is welcomed.
Amit

Re: Upload "chokes" my adsl connection   25 March 2006, 02:49

One more thing..

Shoutcast radio seems to work without skipping while shoutcast tv doesnt and also, web browsing is crawling all this ofcourse when a P2P is uploading at max speed.

Sometimes you can get the answer faster if you try the forum search and/or have a look at the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • If possible, check your spelling and grammar.

Author:

Email:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

  *******   **     **  **     **  ********  ******** 
 **     **  **     **  **     **  **    **  **       
 **     **  **     **  **     **      **    **       
  ********  **     **  **     **     **     ******   
        **   **   **   **     **    **      **       
 **     **    ** **    **     **    **      **       
  *******      ***      *******     **      **       

Message: