Pass Public IP with BWM using Routes

Started by Lucas Alexandre

Pass Public IP with BWM using Routes   02 September 2010, 06:13

Hi Guys,

How I pass public IP's to my customers using routes?

I have three Pool's IP and only one Gateway

189.23.77.234/30
189.23.77.233 GW

201.65.64.192/28
187.029.016.1/24

How do it on windows?

Pass Public IP with BWM using Routes   02 September 2010, 10:58

I am doing these tests, but no sucess...

SERVER:

LAN 1 - Connected to Internet (and working fine)
189.23.77.234
255.255.255.252
189.23.77.233
DNS1: OPENDNS
DNS2: OPENDNS

LAN 2 - Connected to my Local Lan
187.29.16.1
255.255.255.0

STATIC ROUTE ON SERVER: route ADD 187.29.16.0 MASK 255.255.255.0 189.23.77.233 -p

--------------------------------------------------------------

PC1:
LAN:
187.29.16.2
255.255.255.0
187.29.16.1
DNS = OPENDNS


Results: PC1 don't have Internet...

What I am doing wrong?
SoftPerfect Support forum - Andrew avatar image

Pass Public IP with BWM using Routes   02 September 2010, 18:56

Hi Lucas, what exactly you are trying to achieve? There might be a better way smile

Pass Public IP with BWM using Routes   02 September 2010, 22:42

Hi Andrew!

I try to explain better...

My Network:

LAN1 Server With BWM ----> WAN (ISP)
Customers ----> Switch ----> LAN2 Server With BWM

My ISP gave to me a pool of 254 Valid IP in this subnet: 187.029.016.0/24

I need to distribute a public ip on this pool for some of my clients...
-----------------------------------------------------------------------------------

My ISP gave me only one gateway (189.23.77.233), this gateway is out of the above subnet (187.29.16.0)...

I had sucess using Bridge on BWM with this configuration:

MY SERVER (WITH TWO LAN IN BRIDGE):
LAN1: (connected to a ISP router)
IP: 189.23.77.234
MASK: 255.255.255.252
GATEWAY: 189.23.77.233
DNS: OPENDNS

LAN2: (connected to Switch)
IP: No Matter (using bridge in BWM)

CUSTOMER (WINDOWS OS):
IP: 187.29.16.1
MASK: 255.255.255.0
GATEWAY: 189.23.77.233 (see? this subnet is out of 187.29.16.0, but in Windows XP this setup works, in Linux this setup don't work because the OS don't accept gateway in other subnet)
DNS: OPENDNS
-----------------------------------------------------------------------------------

So... I need to create some way to gave these public ips on this subnet to my customers, and I have no ideas to do this on windows (there was many examples on internet to do this using routes on mikrotik)

I was doing some tests, but I am still not have sucess on Windows...

MY TESTS:

MY SERVER WITH BWM (No bridging - all of bwm rules dissabled):

LAN1: (connected to a ISP router)
IP: 189.23.77.234
MASK: 255.255.255.252
GATEWAY: 189.23.77.233
DNS: OPENDNS

LAN 2: (connected to switch)
187.29.16.1
255.255.255.0

I create a Static route on the server to routing connections from 187.29.16.0 Subnet to a 189.23.77.233 gateway...

Command: route ADD 187.29.16.0 MASK 255.255.255.0 189.23.77.233 -p
PS: Creating this route, the clients can't ping to 187.29.16.1
--------------------------------------------------------------
CUSTOMER:
LAN: (connected to switch)
187.29.16.2
255.255.255.0
187.29.16.1 (my server)
DNS = OPENDNS

Results: No sucess.
--------------------------------------------------------------

Considerations:

1- Briding in BWM works, but other OS like Linux don't accept gateway on other subnet
2- If Briding don't works, Is possible to do this on Windows using routing? (In mikrotik is possible)
3- Maybe my command (route ADD 187.29.16.0 MASK 255.255.255.0 189.23.77.233 -p) is Wrong.

Cheers

Lucas Alexandre

Pass Public IP with BWM using Routes   04 September 2010, 03:38

anybody??

Pass Public IP with BWM using Routes   04 September 2010, 05:25

Hi Lucas,

I'm trying to help.. BUT..... !!!!!!! sad

Pass Public IP with BWM using Routes   04 September 2010, 08:02

Hahahaha... but you understand what I want?

Pass Public IP with BWM using Routes   06 September 2010, 08:52

Somebody help!smile
Leoco

Pass Public IP with BWM using Routes   09 September 2010, 02:49

HI

I am looking at your config, you are using BWM in bridge mode. I dont see where you have a router.

My setup looks like this [Provider <router> BWM <router> Customers].

If you are using BMW in bridge mode it will pass traffic based on rules but will not route.

Thanks

Leoco

Pass Public IP with BWM using Routes   09 September 2010, 03:09

Hi Leoco,

Yes, I have sucess with Bridging, but I have to do this without bridge.

Thanks!
Leoco

Pass Public IP with BWM using Routes   10 September 2010, 10:55

HI,

What function are you trying to get BWM do for you. Maby that will help up help you Better.

Leoco

Pass Public IP with BWM using Routes   10 September 2010, 12:33

Hi

I need to make it work with BWM disabled. (only doing routing).
I will use Bwm only for throttle the public ip's that I will give to my customers

Thanks
Leoco

Pass Public IP with BWM using Routes   11 September 2010, 13:14

Hi,

BWM runs on windows and need internet connection sharing or routing and remote access enabled on there windows server you are using. both of these are limited in what they can do. If you set up your own router you can use BWM in bridge mode. in your case it looks like your needing BWM or more specifically the box to share that internet connection.


Am I getting closer?

Leoco

Pass Public IP with BWM using Routes   11 September 2010, 15:55

I need to do it (initially) with BWM disabled... and do it on windows using routes...

see my example:

MY TESTS:

MY SERVER WITH BWM (No bridging - all of bwm rules dissabled):

LAN1: (connected to a ISP router)
IP: 189.23.77.234
MASK: 255.255.255.252
GATEWAY: 189.23.77.233
DNS: OPENDNS

LAN 2: (connected to switch)
187.29.16.1
255.255.255.0

I create a Static route on the server to routing connections from 187.29.16.0 Subnet to a 189.23.77.233 gateway...

Command: route ADD 187.29.16.0 MASK 255.255.255.0 189.23.77.233 -p
PS: Creating this route, the clients can't ping to 187.29.16.1
--------------------------------------------------------------
CUSTOMER:
LAN: (connected to switch)
187.29.16.2
255.255.255.0
187.29.16.1 (my server)
DNS = OPENDNS

Results: No sucess.
--------------------------------------------------------------

Thanks for help
Leoco

Pass Public IP with BWM using Routes   13 September 2010, 14:47

HI Lucas

I think I see a bit more what you are trying to do. You say that the 187.29.16.2 cant ping 187.29.16.1, That may be a hardware issue. Try removing that route you added.

Also windows server out of the box WILL NOT route traffic. What service so you plan on using to route traffic? Some come with windows and there are Microsoft Packages as well as third party solutions.

I can still see that you may not have routing happening on your network.


Leoco

Pass Public IP with BWM using Routes   14 September 2010, 20:45

I don't know how to do this work.
Leoco

Pass Public IP with BWM using Routes   16 September 2010, 11:20

HI,

You can have your server do some of what you want it do.

Install the routing and remote access service on your server, Run through the wizard and tell it that you are setting up a NAT server. Lan 1 is your internet source,

After it is configures your computers connected to lan 2 will be able to access the internet through the server.

I don't believe this is everything you want to do but at least it will give access to browse.

You need to be thinking of setting up a router.

I hope this will help

Leoco

Pass Public IP with BWM using Routes   17 September 2010, 06:39

Leoco,

But, with NAT I will share the WAN ip for all of my "private" clients...

I have one subnet of "valid ip" but it is not on the same subnet of the gateway:

201.65.64.192/28 (valid ip)
187.029.016.1/24 (valid ip)

my gateway: 189.23.77.233

Sometimes you can get the answer faster if you try the forum search and/or have a look at the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • If possible, check your spelling and grammar.

Author:

Email:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

 **     **  **    **  **     **   ******   ********  
 **     **   **  **   **     **  **    **  **     ** 
 **     **    ****    **     **  **        **     ** 
 *********     **     **     **  **        **     ** 
 **     **     **      **   **   **        **     ** 
 **     **     **       ** **    **    **  **     ** 
 **     **     **        ***      ******   ********  

Message: