Networx not showing all users

Started by Ingmar Snippe

Ingmar Snippe

Networx not showing all users   26 October 2012, 22:02

Hello there!

I am trying out Networx now, since it helps me monitoring different domains to see the throughput. We are working with terminal servers with a number of users on it, Windows 2003 stil..

The funny thing is, that when I turn Networx on, it immidiatly finds 2 users (Administrator and one other domain user that is logged on). But all the other users are not to be shown in the usage report. I first thought it was a permission problem, but the only normal user that is correctly logged is no admin. Just a normal domain user, like the rest.

What could explain for users not showing the the usage report? I know they are sending data, they are logged in, not idling and are using applications that generate netwerk traffic.

Kind regards,

IR Snippe
ed1

Networx not showing all users   27 October 2012, 12:22

I had a similar issue recently on a home network with two computers. The network usage of only one was being reported in Networx, though on both Networx was running and set to communicate with other computers on the network.

Per Andrew's suggestion, I checked the Windows firewall listing of programs allowed through the firewall. The problem immediately resolved itself when Networx was given permission to pass through the Windows firewall. This was done in the Windows firewall settings.
Ingmar Snippe

Networx not showing all users   29 October 2012, 20:42

The server is located in our LAN and doesn't have to pass through our corperate firewall. The windows firewall is off. I checked application control and DPI logs, but networx should be able to function without restrictions. It's probably a permission related issue, but I can't figure out what.

Some users show direct results in usage report, some only after the end of the day or the measured values are zero.
mw

Networx not showing all users   16 November 2012, 06:46

I have the same problem. In usage report I can see only "All user combined" and "Administrator". That is of no significance which option I choose. I always can see the same amout of send and received data. But I know that other users have used a computer.
Can you explain it for me?
SoftPerfect Support forum - Andrew avatar image

Networx not showing all users   16 November 2012, 10:04

If the other users logged on as the administrator, NetWorx has no way of knowing who really sat in front of the monitor smile
mw

Networx not showing all users   18 November 2012, 05:19

Andrew Wrote:
-------------------------------------------------------
> If the other users logged on as the administrator,
> NetWorx has no way of knowing who really sat in
> front of the monitor smile

But they are logged on with a different names.
Question stays still open.

Networx not showing all users   18 November 2012, 22:04

Quote

But I know that other users have used a computer.


Check the firewall rules for each user...

Networx.exe must be set to Allow connections:
for both receive Inbound and send Outbound,
for both TCP & UDP.

If Blocked (or Not Allowed), Networx can't access the information.

If you want to see the traffic for all users on the 'main' computer, you have to set that up to synchronize usage data. See the Settings > Advanced tab and read the help file.

J
mw

Networx not showing all users   19 November 2012, 06:40

Finally I found a solution for my problem.
I am constantly logged on to an administrator account with remote desktop.
When Networx is running on the administrator account, (despite the fact, that other users are also log on to the computer), the whole traffic is assigned only to the administrator account (even though that, two instances of Networx are running, one for admin and second for another logged-in user).
I'm not sure, but perhaps there is a situation when at the same time to a computer, are logged many users but all traffic is assigned to the account of the one who first logged on to the system and launched the first instance of Networx.
When I closed a Networx on the administrator account without log out from a system, and I logged another user on, entries appeared about him in counters of Networx.
If authors of the program are reading this forum, please check my suspicions and consider this issue as a bug.

Thank you to everyone who showed interest in the topic.

MW.
SoftPerfect Support forum - Andrew avatar image

Networx not showing all users   19 November 2012, 09:38

It's not a bug. NetWorx has no way of distinguishing what user to attribute traffic to when more than user is logged on. In this case all traffic is recorded as the first logged user. If that user logs off, then all traffic is recorded as the next logged user and so on.
TheInternet

Re: Networx not showing all users   06 September 2016, 17:39

Yet it can see which application is using the bandwidth..

but can't view the session ID that has the PID open ?
SoftPerfect Support forum - Andrew avatar image

Re: Networx not showing all users   06 September 2016, 17:56

No, we don't extract or keep session information.

Sometimes you can get the answer faster if you try the forum search and/or have a look at the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • If possible, check your spelling and grammar.

Author:

Email:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

  *******   **    **  **        **     **  **    ** 
 **     **   **  **   **         **   **    **  **  
 **           ****    **          ** **      ****   
 ********      **     **           ***        **    
 **     **     **     **          ** **       **    
 **     **     **     **         **   **      **    
  *******      **     ********  **     **     **    

Message: