Possible memory leak

Started by xrmb

Possible memory leak   08 October 2016, 11:17

SoftPerfect support forum

OS: win 2012 R2

It was running for a week, last night it was at normal memory usage. I don't think anything special happened in the last 24hrs. I have seen it before, but installed an update since, hoping it was fixed. Guess not.

Let me know if there is anything I can do to help debug, like a memory dump or something.
SoftPerfect Support forum - Andrew avatar image

Re: Possible memory leak   08 October 2016, 11:45

Please post here a screen shot of the Main settings tab in NetWorx, so I could see what options are enabled.

Re: Possible memory leak   09 October 2016, 02:00

SoftPerfect support forum

I also have the tray-icon and mini overview window open all the time.

The weird part is that it works fine for many days, and then suddenly shoots up in usage.
SoftPerfect Support forum - Andrew avatar image

Re: Possible memory leak   09 October 2016, 14:25

It could be an app that opened a lot of sockets, but not closed them for a long time.

Try going to the Hidden Settings and set Keep track of TCP/UDP connections to False.

Re: Possible memory leak   10 October 2016, 00:27

Ok, I changed the tracking and restarted. There shouldn't be many connection opened/closed. I'll check back in a week, lets hope for the best.

Thanks for the great apps and support!

Re: Possible memory leak   16 October 2016, 23:05

It is happening again right now, I still have Networx running since there is a little memory left in the page file. I'll take a memory dump with windbg (if I can figure out how).

Re: Possible memory leak   17 October 2016, 08:35

Ok, I have a full and "full minidump", each one is 750mb (500mb compressed). Let me know if it is of any potential use.

I also noticed this: when I logged in the computer Networx was at 2.5gb memory, I closed my torrent client and the memory usage dropped to 750mb. Not sure if it is related, but it sure looks like it. But the torrent client is open 24/7, and so is Networx. According to its own logging the torrent client does around 400k connections per day, but I have not seen any memory increase for Networx in the last 10hrs. Of course there are a few other programs that use the internet running.
SoftPerfect Support forum - Andrew avatar image

Re: Possible memory leak   17 October 2016, 12:03

It's probably not so useful as NetWorx doesn't come with debug information and we won't be able to determine what has consumed the memory.

I'd suggest to turn off the Ignore LAN traffic option. In this case NetWorx will merely collect network adapter statistics and memory usage should always stay low.

Re: Possible memory leak   18 October 2016, 10:35

Since the computer is directly connected to the internet I had the "ignore all LAN traffic" already checked. Also in the last 24h the memory usage went up 2mb only, with traffic as usual.

Is there a version with debug symbols available? Looks like I am the only one with that problem sad
SoftPerfect Support forum - Andrew avatar image

Re: Possible memory leak   18 October 2016, 11:54

I am not sure if I understand what you said, but if the computer is connected directly to the Internet, there's really no point in having Ignore all LAN traffic checked. If you turn it off, you will lose the ability to track traffic by application, but shouldn't be any memory leaks.

We could make a debug version and run through a tool like Dr Memory, in fact you can do it even without debug builds - but I am afraid in the end we'll just find a buggy third-party DLL or something like that.
firstrose

Memory leak?   08 November 2016, 19:00

SoftPerfect support forum

I looked up process status by Process Hacker.

SoftPerfect support forum

SoftPerfect support forum

SoftPerfect support forum

Networx consumes lots of memory as heap segments....

SoftPerfect support forum

Win7 x64
SoftPerfect Support forum - Andrew avatar image

Re: Memory leak?   08 November 2016, 19:22

As mentioned above, it could be an app that opened a lot of sockets, but not closed them for a long time. Try going to the Hidden Settings, set Keep track of TCP/UDP connections to False, and restart NetWorx.

Reply to this topic

Sometimes you can get the answer faster if you try the forum search and/or have a look at the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • If possible, check your spelling and grammar.

Author:

Email:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

 **    **  **      **  **    **  **    **  **       
  **  **   **  **  **   **  **    **  **   **       
   ****    **  **  **    ****      ****    **       
    **     **  **  **     **        **     **       
    **     **  **  **     **        **     **       
    **     **  **  **     **        **     **       
    **      ***  ***      **        **     ******** 

Message: