New beta version 3.4

Started by Andrew

Robert Lee

New beta version   11 June 2013, 23:49

I test on my new NB one month ago, because my new NB is fast enough, I uninstall ramdisk.
Today I try to install at My old XP NB
Maximization

New beta version   13 June 2013, 09:35

Hi,
Was planning to try Ram disk software for a year and have a new system to actually try it. I want to see how this beta works in Windows 8. I have duel HD , Duel OS's, I am using Windows 8 for fun, I am keeping Vista 64 Ultimate for work stuff. Since I have never set up a ram disk I am sure I will mess up, from what I have read I plan on setting up a cache drive for speed to lower HD usage.

specs for my system

Intel Core i7 3820
G.Skill F3-12800CL10-8GBXL
size: 64 GBytes
HZ281H HANNS-G 27.5"
RAVEN 03
RAMPAGE IV EXTREME
WESTERN DIGITAL WD5000HHTZ-0
Antec K├╝hler H20 920
AMD Radeon HD 7870 Series Diamond multimedia(x2)
VISTA 64 ULTIMATE
SEASONIC SS-850KM ACTIVE PFC F3
Maximization

New beta version   14 June 2013, 08:35

Was able to set ram disk and format with no problem so far in Win 8, I need to mess around with it more i am sure I will have questions soon. smile
Cloud

New beta version   14 June 2013, 11:18

Hi
I have used the Hard Disk Emulation 3 days,and no BSOD when start Windows7.
But it cant work set pagefile in ramdisk
Maximization

New beta version   21 June 2013, 14:19

I am very impressed so far, i can easily set a ramdisk. I like to overclock and benchmark, i noticed when i pushed 5Ghz with a high BLCK my HD got errors. I am assuming the more you overclock the more unstable the ramdisk might become, due to my settings , windows 8 or so many other things. With just mulitplier overclocks it works like a dream though. Any software executes fine off the ramdisk.
LordJZ

New beta version   23 June 2013, 19:33

Hi,

Any news on the Windows 8 Task Manager incompatibility problem?

Thanks.
tridex

New beta version   26 June 2013, 09:01

Excellent software!!!!!

works perfect smile windows server 8 , 16 gig ram with 8 gig ramdisk ...


Thank you very much and good luk with fture versions ...


made my day !!!

New beta version   27 June 2013, 10:48

It became impossible to make a pagefile.sys to ramdisk.

Win7 64
speed8

New beta version   27 June 2013, 14:23

If you have enough RAM you can disable the pagefile. Or choose a custom size of the pagefile, and select the ramdisk as a drive.
SoftPerfect support forum

New beta version   27 June 2013, 14:58

To speed8

I can make pagefile with old version of Softperfect Ramdisk.
But this new beta version 3.4, I can not make it.

New beta version   27 June 2013, 15:15

To speed8 2

I set up like you said.
But OS dos not make pagefile to the Ramdisk.
There is no pagefile.sys on the Ramdisk after reboot system.
Jyro117

New beta version (Windows 8.1)   28 June 2013, 05:06

Couple notes about Windows 8.1 and Ramdisk:

Version 3.3 doesn't run, error on app startup.
Version 3.4 beta, causes issues with Task Manager. After mounting a disk it cause Task Manager to crash and also locks up the Task Manager when you are on the performance tab.
LordJZ

New beta version (Windows 8.1)   28 June 2013, 07:13

Task Manager issues present not only in Win 8.1, but in Win 8 too.
Ferman

New beta version (Windows 8.1)   29 June 2013, 19:28

Beta 3.4 working on W8.1 without any issues. Task Manager also works fine.
Windows 8.1 Pro x64 (english and russian), updated from Windows 8 Pro x64. There was Task Manager crashes before update of Windows with Ram Drive version 3.3.3.
Rob

BLUE SCREEN with 3.4   29 June 2013, 20:36

I have installed on my NB DELL XPS i7+SSD the version 3.4 win 7-64 and at any reboot (for 3-4 time) i have windows BLUE SCREEN and nb dead!.
Message: driver in conflict with HW
Now i have killed from NB the rel.3.4 and now start the test with the 3.3.3......(!?)
Kees

New beta version   02 July 2013, 02:16

I'm having events 11 (yellow) Sourcelaughisk, subscription: controller failure and 32 (red) Source: Disk, subscription Write cache enabled at every startup on my Windows 8 pro X64 system

I'm using a disk size 4 Gb with Harddisk emulation enabled for pagefile.sys and temp files( such as IE10)

New beta version   11 July 2013, 07:34

This has been working fine on my main gaming system but on a system I'm building for my brother, I've been having some BSOD and lockups. They may not have been caused by SoftPerfect but someone analysed one of the minidumps for me and it refers to the SoftPerfect drivers, so I thought you'd like to take a look. I'll upload the dump for you to look at yourself if you'd like, just let me know.

By the way, on this system I just created a 1GB Boot RAMDisk, which mounts with only a TEMP folder. Then I saved it and compressed it with NTFS, so it only occupies 12.0KB on the HDD. It was mainly going to be used to hold MediaPortal's timeshifting files but I never got round to actually using it, other than having it mounted at boot.

.
*** WARNING: Unable to verify timestamp for spvve.sys
*** ERROR: Module load completed but symbols could not be loaded for spvve.sys
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 1000007E, {ffffffffc0000005, fffff800033de308, fffff880009a9098, fffff880009a88f0}

Probably caused by : spvve.sys ( spvve+1b6ca )

Followup: MachineOwner
---------

0: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

SYSTEM_THREAD_EXCEPTION_NOT_HANDLED_M (1000007e)
This is a very common bugcheck.  Usually the exception address pinpoints
the driver/function that caused the problem.  Always note this address
as well as the link date of the driver/image that contains this address.
Some common problems are exception code 0x80000003.  This means a hard
coded breakpoint or assertion was hit, but this system was booted
/NODEBUG.  This is not supposed to happen as developers should never have
hardcoded breakpoints in retail code, but ...
If this happens, make sure a debugger gets connected, and the
system is booted /DEBUG.  This will let us see why this breakpoint is
happening.
Arguments:
Arg1: ffffffffc0000005, The exception code that was not handled
Arg2: fffff800033de308, The address that the exception occurred at
Arg3: fffff880009a9098, Exception Record Address
Arg4: fffff880009a88f0, Context Record Address

Debugging Details:
------------------


EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

FAULTING_IP: 
nt!IopPerfCompleteRequest+58
fffff800`033de308 488b4cc270      mov     rcx,qword ptr [rdx+rax*8+70h]

EXCEPTION_RECORD:  fffff880009a9098 -- (.exr 0xfffff880009a9098)
ExceptionAddress: fffff800033de308 (nt!IopPerfCompleteRequest+0x0000000000000058)
   ExceptionCode: c0000005 (Access violation)
  ExceptionFlags: 00000000
NumberParameters: 2
   Parameter[0]: 0000000000000000
   Parameter[1]: ffffffffffffffff
Attempt to read from address ffffffffffffffff

CONTEXT:  fffff880009a88f0 -- (.cxr 0xfffff880009a88f0)
rax=0000000000000000 rbx=fffffa8006dabc88 rcx=0000000000000000
rdx=00670061006e0061 rsi=fffff880009a9400 rdi=fffffa8006dabb70
rip=fffff800033de308 rsp=fffff880009a92d0 rbp=0000000000000000
 r8=0000000000000000  r9=fffffa80072ed000 r10=0000000000401802
r11=fffff880009a93a0 r12=0000000000000001 r13=ffffffff800000fc
r14=fffffa801b57c870 r15=000000000000001c
iopl=0         nv up ei ng nz ac pe cy
cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00010293
nt!IopPerfCompleteRequest+0x58:
fffff800`033de308 488b4cc270      mov     rcx,qword ptr [rdx+rax*8+70h] ds:002b:00670061`006e00d1=????????????????
Resetting default scope

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  WIN7_DRIVER_FAULT

PROCESS_NAME:  System

CURRENT_IRQL:  0

ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

EXCEPTION_PARAMETER1:  0000000000000000

EXCEPTION_PARAMETER2:  ffffffffffffffff

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff80003512100
GetUlongFromAddress: unable to read from fffff800035121c0
 ffffffffffffffff 

FOLLOWUP_IP: 
spvve+1b6ca
fffff880`02c426ca ??              ???

BUGCHECK_STR:  0x7E

LAST_CONTROL_TRANSFER:  from fffff88002c426ca to fffff800033de308

STACK_TEXT:  
fffff880`009a92d0 fffff880`02c426ca : fffffa80`1b5997f0 00000000`00000000 fffff880`009a9450 20206f49`00000001 : nt!IopPerfCompleteRequest+0x58
fffff880`009a9380 fffffa80`1b5997f0 : 00000000`00000000 fffff880`009a9450 20206f49`00000001 00000000`00000000 : spvve+0x1b6ca
fffff880`009a9388 00000000`00000000 : fffff880`009a9450 20206f49`00000001 00000000`00000000 fffff880`02c421d6 : 0xfffffa80`1b5997f0


SYMBOL_STACK_INDEX:  1

SYMBOL_NAME:  spvve+1b6ca

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: spvve

IMAGE_NAME:  spvve.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  51a82acd

STACK_COMMAND:  .cxr 0xfffff880009a88f0 ; kb

FAILURE_BUCKET_ID:  X64_0x7E_spvve+1b6ca

BUCKET_ID:  X64_0x7E_spvve+1b6ca

Followup: MachineOwner
---------

0: kd> lmvm spvve
start             end                 module name
fffff880`02c27000 fffff880`02c90000   spvve    T (no symbols)           
    Loaded symbol image file: spvve.sys
    Image path: \??\C:\Program Files\SoftPerfect RAM Disk\spvve.sys
    Image name: spvve.sys
    Timestamp:        Fri May 31 10:15:01 2013 (51A82ACD)
    CheckSum:         0006FFD2
    ImageSize:        00069000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
0: kd> lmvm spvdbus
start             end                 module name
fffff880`03f60000 fffff880`03f85000   spvdbus    (deferred)             
    Image path: \SystemRoot\system32\DRIVERS\spvdbus.sys
    Image name: spvdbus.sys
    Timestamp:        Fri May 31 10:15:00 2013 (51A82ACC)
    CheckSum:         00028B1A
    ImageSize:        00025000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
Alex

New beta version   20 July 2013, 06:07

Maybe add a ramdisk to create an invisible memory above 3.25GB for WinXP (installed 4GB)?
Alex

New beta version   23 July 2013, 23:02

Bond RAMDisk (http://www.bonddisc.com) have more performance about 10-15%, checked in CrystalDiskMark.
Martigen

New beta version   24 July 2013, 11:04

RE: Dynamic RAM disk
VD:
>> I mean does this ramdisk has the possibility to
>
>No, and we aren't sure that this feature is really demanded.

Absolutely it is! This is one of the more exciting developments with RAM drives.

Just one use off the top of my head: the classic moving TMP/TEMP to the RAM drive. You've got a 16GB system, how much do you allocate? If you allocate say 4GB, it might be too little for some large operations, causing programs using TEMP to fail. Sure, so allocate say 10GB then -- but now you've got 10GB RAM locked up in the RAM drive that no other programs, disk cache, etc can use causing programs to start swapping out to disk if you run out of main memory. Neither situation is ideal.

However, with dynamic memory allocation you could set up a 14GB RAM disk and this entire area remains free for system programs while nothing is in the RAM disk. If an operation needs 5GB of TEMP, then 5GB of the RAM disk is used but the remaining space is still free memory for programs. Then, of course, as soon as the TEMP operation completes, the RAM is freed up again.

There are so many benefits to a dynamic RAM disk -- please consider it for the next version smile
SoftPerfect Support forum - Andrew avatar image

New beta version   25 July 2013, 21:25

The beta-version has been updated today to include bug fixes in the kernel driver and a couple of improvements in the application itself: it's now possible to create an image directly from the Add Disk dialog and it's a RAM disk with image file attached can be flushed to file manually.
Joe Lynch

New beta version   25 July 2013, 22:44

Dynamic RAM disk feature would be really useful for 32-bit systems where memory is limited, and where every MB counts.
Nice article: -[www.romexsoftware.com]-
Kees

New beta version   26 July 2013, 05:05

With the july 25th driver version, I'm still experiencing this System Event warning at startup of my Windows 8 pro X64 system

I'm using a disk size of 4 Gb with Harddisk emulation enabled for pagefile.sys and temp files.

Logboeknaam:   System
Bron:          disk
Datum:         25-7-2013 20:55:13
Gebeurtenis-id:32
Taakcategorie: Geen
Niveau:        Waarschuwing
Trefwoorden:   Klassiek
Gebruiker:     n.v.t.
Computer:      MS7667
Beschrijving:
Het stuurprogramma heeft ontdekt dat bij het apparaat \Device\Harddisk4\DR4 schrijfcache is ingeschakeld. Hierdoor kunnen gegevens worden beschadigd.
Gebeurtenis-XML:
<Event xmlns="[schemas.microsoft.com];
  <System>
    <Provider Name="disk" />
    <EventID Qualifiers="32772">32</EventID>
    <Level>3</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2013-07-25T18:55:13.157110500Z" />
    <EventRecordID>84775</EventRecordID>
    <Channel>System</Channel>
    <Computer>MS7667</Computer>
    <Security />
  </System>
  <EventData>
    <Data>\Device\Harddisk4\DR4</Data>
    <Binary>0F00100001000000000000002000048001000000000000000000000000000000000000000000000000000000000000000000000001000000</Binary>
  </EventData>
</Event>
TRIDEX

New beta version july25 EXCELLENT ...   26 July 2013, 07:33

July 25th version BETA is Excellent software!!!

Works perfectly smile on windows server 8, 16 GB ram with 8 GB ramdisk ...

OK HAD SOME PROBLEMS
I FIXED THEM BU DELETE ALL REGISTRY KEY VALUES [REGEDIT] TO DO WITH "softperfect", FOR SOME REASON NORMAL UNISTALL DID NOT REMOVE ALL REFRENCES!
NOW WORKS LIKE A CHARM AND I GOT 20% SPEED INCREASE ON THIS VERSION!!!!

Thank you very much and good luck with future versions ...

Made my day !!!
Kees

New beta version   29 July 2013, 03:48

After a clean W8 Pro install, this new version will install but won't startup automatically with Windows anymore, like before when i upgraded via v 3.3.3 > first beta > this vesion.
Jaga

New beta version   30 July 2013, 12:09

Not getting any BSOD with latest beta (3.4.0 64-bit). Win7x64 Ultimate, Q6600 w/48gb RAM. Settings used: 15gb NTFS image created on C: (Image type Hard Disk), added as Boot Disk with Hard Disk Emulation. Speeds not that much slower than before emulation (still much greater than one order of magnitude faster than my fastest SSD drive).

Additionally the issue I was having with Restore points not being created is fixed. Great beta version in my opinion.
Kees

New beta version   31 July 2013, 00:44

Had to cycle power off and on, then it worked again. Soft reboot apparantly wasn't enough.
Still getting events 11 and 32 though.
Ghost

exFAT format support?   31 July 2013, 03:23

I'd love to see a format option for exFAT in this software. I use RAM disks to render and edit projects in Adobe Photoshop, Illustrator, Flash, Premier, and After Effects in real time. OH how I would love to fit a 5+ GB file on one of these RAM disks without using NTFS.

New beta version   01 August 2013, 01:09

I had a couple of BSOD after installing the latest version. Perhaps you could check the attached debug logs and let me know if they were related to SoftPerfect or not?

I haven't had any since uninstalling it again (fingers crossed) but that might just be a coincidence.

I'm wondering if it might not be playing nice with my onboard ATI graphics, which is using 256MB UMA system RAM?
Attachments:
open | download – 073113-17019-01.zip (42.2 KB)

New beta version   01 August 2013, 02:21

Hmm, it seems I had a problem with my fonts. I'm not using Firefox but this helped me fix it

[support.mozilla.org]

It BSOD every time I tried to open Windows\Fonts or Control Panel - Fonts (or tried to search C:, which was obviously accessing Windows\Fonts), so I had to use \\PCNAME\C$\Windows\Fonts, select all 446 fonts and click Install to re-install them.

I can't help but wonder how the fonts get so messed up that they were causing BSOD though but it's probably unrelated to SoftPerfect.

Reply to this topic

Sometimes you can get the answer faster if you try the forum search and/or have a look at the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • If possible, check your spelling and grammar.

Author:

Email:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

 ********  **    **   *******   **    **  **     ** 
 **        **   **   **     **   **  **   ***   *** 
 **        **  **    **     **    ****    **** **** 
 ******    *****      ********     **     ** *** ** 
 **        **  **           **     **     **     ** 
 **        **   **   **     **     **     **     ** 
 ********  **    **   *******      **     **     ** 

Message: