Occasionally failing to save image to disk

Started by WebEye


Occasionally failing to save image to disk   19 December 2015, 22:23


First I love this software, after trying some other Ram disks!
But I've got a strange issue, I've got one 3GB bootable image, which is saved at shutdown. But this doesn't work every time, I tried out fat-32 as well as ntfs, sometimes it isn't saved at shutdown. I know about it from the timestamp of the image file, and primarily because of the lost data. So I do some tests and save the image manually before shutdown, and if I do so both savings do work, the manual and the automatic. But if I left the manual saving, the automatic saving does not work all time.

So do someone have a solution for this? Is there any log I can search for this error? Here are system specs:
Win 7 x64 (Sp1)
32GB installed RAM
The image is saved on a partition of a non-system HDD

So I think I will try to install a planned task to save the image at shutdown and stop the automatic saving. Maybe this will work, but I'm open to suggestions.

SoftPerfect Support forum - Andrew avatar image

Re: failed saving image to disk   21 December 2015, 00:21

Sorry, I have no idea. Generally saving data to the image file at system shutdown is pretty simple in terms of implementation, but there's a chance writing may take a while and the system aborts it before it completes.

It's more reliable to initiate the save manually and wait until it completes before shutdown, or may be even not use an image file at all and backup files using a utility like Robocopy or Unison.

Re: Occasionally failing to save image to disk   21 December 2015, 21:19

Hi Andrew,

thanks for support! I've recently disabled automatic saving and added a shutdown script in Windows Group Policy Editor, which saved my image. This works now two times in a row, maybe this is a workaround for me. Otherwise I will try automaticly saving all few minutes, or even robocopy or something. I will inform you...

Perhaps you are able to implement an error log in next versions to debug these strange things.

Thank you,

Re: Occasionally failing to save image to disk   24 December 2015, 20:54

I just want to inform you that saving via shutdown script works for me, since then I had no missing saving.

Happy holidays!
SoftPerfect Support forum - Andrew avatar image

Re: Occasionally failing to save image to disk   24 December 2015, 22:41

Thanks, it's good to know.

Re: Occasionally failing to save image to disk   17 January 2016, 00:50

sorry for reactivating this thread!

But I realize "/save:driveletter" in Shutdown script won't work proper, too! Sometimes it hangs at the shutdown screen and only a hard reset helps. But I think the reason for this is, that the save process hits a system locked file and the application throws a message...

So my next step was to replace the "/save:driveletter" script with a robocopy script, to mirroring the image bound ramdisk to another place on the hdd! i tested it for a while, and in fact there where two files which are sometimes locked from the system (foobar2000 and thunderbird files), so I exclude these files and this part works proper.

So now comes the strange thing, I thought, I need a restore script, too, but the Shutdown script updates the image file, too, and I do not understay why!? Is this ok, or is this a bug? Maybe you can explain this process wink

Maybe a feature for the future: another parameter to do the process in silent mode, not to throw (error)messages.

SoftPerfect Support forum - Andrew avatar image

Re: Occasionally failing to save image to disk   17 January 2016, 01:25

If you need to copy locked files, try using hobocopy. For it to work you may also need to activate the Hard Disk Emulation option in the RAM Disk's properties.

Regarding 'Shutdown script updates the image file', I am not quite sure what you mean. It's your file after all, I can't know what you programmed in it wink

Re: Occasionally failing to save image to disk   17 January 2016, 02:14

Ok, more detailed information:

I've got a 3GB ntfs Ramdisk "Z:" bound to "F:\Ramdisks\HDDZ.img"
With following script, I backup the ramdisk:

robocopy "z:" "f:\Ramdisks\HDDZ" /R:20 /W:5 /MIR /XF "Z:\Users\...\AppData\Roaming\foobar2000\running" "Z:\Users\...\AppData\Roaming\Mozilla\Firefox\Profiles\mo03ij0d.default\parent.lock" /LOG:"F:\Ramdisks\Backup.log"

These script runs at group policy windows-shutdown.
When the script runs, not only ""f:\Ramdisks\HDDZ" was updated, "F:\Ramdisks\HDDZ.img" will be updated, too!
All other saving methods are disabled.
SoftPerfect Support forum - Andrew avatar image

Re: Occasionally failing to save image to disk   17 January 2016, 21:11

Sorry I have no idea. I guess I'd recommend to monitor what changes the file with Process Monitor.

Better yet, if you backup files with Robocopy now, then you don't need the image file anyway, so simply use a RAM Disk without any attached images.

Re: Occasionally failing to save image to disk   17 January 2016, 21:40

The idea was, I got a base-image and with robocopy I only update the changed files! I thought this is much faster than copy the whole 3GB with robocopy!?
But anyway, somehow it works for me.

When I got time I do a monitoring with process monitor....

Thanks for your support.

I was just about to make a new thread with a similar title, but since my issue looks to the same I might as well continue this thread (sorry if this feels like a hijack)

Basic system info:
- Windows 10 pro
- 512GB Samsung Pro SSD as my C:\ drive.

I just installed the software yesterday, and created an 8 GB image file on the root of my C:\ drive. I added a RAM disk (not Add Boot Disk) and assigned it to that image file. I assigned it to drive letter A:\ . And I made sure to check the "Save contents to image" option in the settings.

I created a folder named "test" on the A:\ drive, then power down. Turning on the PC again, I see that "test" still exists in the A:\ drive. Here's where it gets inconsistent. I created a dummy text file inside of the "test" folder. And on the next power off/on cycle, the the text file would be gone, but the "test" folder is still there. I recreated the dummy.txt, and next time the dummy.txt will be there. Doing this several times, it seems sometimes the dummy.txt will be there after reboot, and sometimes not. But the "test" folder has been there all the time.

So it seems strange to me that some contents of the RAMdisk is saved to the image file after shutdown (the folder), and some not consistently (the dummy.txt) file.

After searching on line, this page mentions that
Note: If you use windows 8 or 10, you may want to disable “hybrid boot” which will make the contents of your ramdrive be wiped upon reboot.

Could this is an issue?

Any ideas?
SoftPerfect Support forum - Andrew avatar image

Re: Occasionally failing to save image to disk   02 March 2016, 11:17

As far as I understand you've created a logon-time disk.

It's okay, but the issue is in this case writing data back to the image is initiated by the GUI app. There's a good chance Windows kills the app before it's able to initiate writing or during that process.

I recommend to try a boot-time disk. With a boot-time disk, a shutdown is intercepted by the RAM Disk driver and it can tell the system it needs time to save the data.

Reply to this topic

Sometimes you can get the answer faster if you try the forum search and/or have a look at the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • If possible, check your spelling and grammar.




A brief and informative title for your message, approximately 4–8 words:


Spam prevention: please enter the following code in the input field below.

 ********  ********  ********   **    **   ******   
    **        **     **     **  ***   **  **    **  
    **        **     **     **  ****  **  **        
    **        **     **     **  ** ** **  **   **** 
    **        **     **     **  **  ****  **    **  
    **        **     **     **  **   ***  **    **  
    **        **     ********   **    **   ******