RAMDisk not working on Windows 11 23H2

Started by WildByDesign

RAMDisk not working on Windows 11 23H2   29 September 2023, 06:50

On 23H2 release of Windows 11, RAMDisk is not working:
  • no RAM disks will save (error states that it cannot save due to another process accessing it).
  • trying to unmount the RAM disk causes entire system to freeze (no task manager, no Win+X, nothing). It requires holding the power button down for 10+ seconds.
  • accessing the actual RAM disk in Explorer causes BSOD.
So far I have tried creating new RAM disks from scratch and they still cause all problems above.

This is a clean install of 23H2. Latest release of RAMDisk.


RAMDisk not working on Windows 11 23H2 - Solved   29 September 2023, 12:25

SOLVED: I was able to solve this issue by completely disabling Windows Defender.
SoftPerfect Support forum - Andrew avatar image

Re: RAMDisk not working on Windows 11 23H2 - Solved   29 September 2023, 15:33

It must then have been a Windows Defender quirk. Thank you for posting the solution. I can confirm that it works here as well, even with the default settings, which I believe have Windows Defender enabled.

SoftPerfect support forum

Re: RAMDisk not working on Windows 11 23H2 - Solved   29 September 2023, 22:03

You're welcome. I assume that this was very likely a rare glitch with Defender.

I will add a bit more details below in case it ever shows up again:

- just finished clean install of 23H2
- installed all drivers
- rebooted several times as per typical clean install of Windows
- installed RAMDisk first (no other 3rd party programs installed yet)
- added a previously working RAMDisk image
- error when saving, full system freeze when unmounting
- rebooted, still experienced issues
- tested by creating a couple of brand new RAMDisk images
- rebooted in between each attempt, still experienced issues
- rebooted
- disabled Windows Defender permanently
- issues all gone

I always reboot in between various testing scenarios just to ensure that I am working with a fresh boot of Windows.

My assumption here is that it was an extremely rare glitch. Likely having something to do with the system being so freshly installed still that not everything had a chance to really settle yet.

Everything is working great now though on 23H2.


Reply to this topic

Sometimes you can find a solution faster if you try the forum search, have a look at the knowledge base, or check the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • Write in English. If possible, check your spelling and grammar.




A brief and informative title for your message, approximately 4–8 words:


Spam prevention: please enter the following code in the input field below.

       **  ********   ********   ********   **     ** 
       **  **     **  **     **  **     **  **     ** 
       **  **     **  **     **  **     **  **     ** 
       **  **     **  ********   **     **  **     ** 
 **    **  **     **  **         **     **   **   **  
 **    **  **     **  **         **     **    ** **   
  ******   ********   **         ********      ***