Network Scanner version 8: User feedback

Started by Andrew

Two small issues with V8:

1. Please consider making it so that pressing "." will not advance to the next IP address octet if the current octet is empty.
For an example of this behaviour you can look at the IP address entry field in Windows network adapter properties. This makes the IP address entry field more intuitive and idiot proof because you simply place a "." between each octet when typing the address, and it is entered correctly regardless of whether or not the octet has 2 or 3 digits in it. Currently in Netscan if you type for instance 172 and then press ".", your first octet is filled, second octet is skipped, and the cursor is sitting in the third octet. Making the . only advance octets when the current one is non-empty seems like it would solve this and make it easier to use.

2. "Find" performance seems much slower than in previous versions.
My saved scan files are about 1600KB. I have about 20 columns. Using Ctrl-F to search results in about a 6 second delay before the first search result is found. The performance seems to depend directly on how many records are traversed, for example if the first search result is nearer to the top of the scan results than the search only takes about 3 seconds. In previous versions of Netscan the search was basically instantaneous for me, I did not have this several second delay.

Been using this software for many years and always find it handy, so thanks!
SoftPerfect Support forum - Andrew avatar image

Re: Dot behaviour when entering IPs; Search performance   07 April 2021, 14:06

Thank you for pointing these issues out.
  1. Regarding the "." symbol for advancing octets. Unfortunately the current behaviour comes from the underlying control we are using. In version 7, it was the native Windows IP address input. In version 8, we had to resort to a cross-platform solution that works on both Windows and macOS. Having said that, we have modified its behaviour so that the cursor does not advance unless the current octet is filled.
  2. Regarding the search performance, we have improved it as well. Now it should search any number of rows instantaneously, like version 7 did.
Please download the new builds and let us know how it works for you.
I tested out the new build you linked and both the IP address entry and search are working great now. Thanks!

Copy-and-paste IP range bug   24 April 2021, 11:37

Long time licensed user. When you copy and paste in the start IP range box and then paste in the end range box, you get 172.291.121. and 172.291.125. Which is unusable. We use copy paste in our daily operations and this has almost completely crippled the use of this software. We have tried to work around it, but it is just so frustrating, years and years of copy paste habit is impossible to break. Would you look into a fix soon. Many Many Thanks. smile
open | download – NetScan 8 IP Range Bug 1 (04-23-2021).png (17.6 KB)
SoftPerfect Support forum - Andrew avatar image

Re: Copy-and-paste IP range bug   25 April 2021, 09:34

Regardless of this being a habit, it is clearly a bug, as pasting an IP address should result in getting exactly that address. Thank you for reporting it!

We have just fixed it and you can download the new builds here.

Scanning for network printers   28 April 2021, 17:33

1) I believe that the app icon broke with the last fix. I open the Scanner and it works fine, but there's a blank icon on the taskbar.
2) Is there any way to just scan for printers?
SoftPerfect Support forum - Andrew avatar image

Re: Scanning for network printers   28 April 2021, 17:46

Thank you, the icon issue was just fixed. Not sure how it happened as it's got back by itself after a rebuild.

Regarding scanning for printers, I don't think there is a reliable way to say whether a specific device is a printer. You can scan for devices with certain ports open. Alternatively, employ the Nmap integration and scan for all devices. Then filter out those with the device type being printer:

SoftPerfect support forum

Update: turns out there is a protocol called WS-Discovery. I will check if we can implement this within our Network Scanner. If so, then it can discover specific device types on demand.

Re: Network Scanner version 8: User feedback   29 April 2021, 09:46

Guys, you absolutely rock! Your Netscanner is the best. Not just for macOS, but of all of them.

Re: Scanning for network printers   30 April 2021, 01:45

Hi Andrew,
WS-Discovery sounds great!!!

There are some issues I want to submit:

1) Favorites Filter doesn't seem to be working.
I created and saved a configuration file to look for the printers (in the meantime if WS-Discovery possible) with a filter for TCP ports (9100, 515, 631) not empty, and reopening netscan with the config file does present the filter in the list. But if I try to use it does not work, and if I try to mark it as favorite does not bring it to the favorites list. I have to redo the filter.

2) After a new application item is created, sorted, and the config saved, it did not appear in the corresponding sorted place. I have to open applications again, sort again and save for it to appear in the correct position.

3) Maybe related to the previous one. After the first sort if I select, on a host, with the mouse right menu, the item for the newly created application option it did not bring that application but another one.
SoftPerfect Support forum - Andrew avatar image

Re: Scanning for network printers   30 April 2021, 14:56

Thanks for the feedback. I am happy to advise that we have implemented Web Services for Devices (WSD) discovery in the latest builds.

You can find it under Actions - WSD Device Discovery. It should detect all WSD-capable devices, of which you can select printers and click Scan Devices to scan them in the main window.

The bugs with filters and applications have been fixed as well.

SoftPerfect support forum

IP address input field   08 May 2021, 00:40

I don't like the new IP address input field because it is tricky
Before : I could type "1" "9" "2" "dot" "1" "6" "8" "dot" > 192.168.
Now : with the same input > 192. .168.
So, no need to type "dot"? > No because when there is only two numbers it goes wrong if you don't use the dot
SoftPerfect Support forum - Andrew avatar image

Re: IP address input field   08 May 2021, 08:06

We have fixed this IP input behaviour on 7 April 2021. Now, entering the dot will only advance the position if there is a filled octet. Therefore typing 192 (dot) 168 (dot) will enter 192.168.

It is likely that you have an earlier build, in which case please download the latest builds.

Reply to this topic

Sometimes you can find a solution faster if you try the forum search, have a look at the knowledge base, or check the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • Write in English. If possible, check your spelling and grammar.




A brief and informative title for your message, approximately 4–8 words:


Spam prevention: please enter the following code in the input field below.

 ********  **     **   *******   **      **  **     ** 
 **         **   **   **     **  **  **  **  **     ** 
 **          ** **    **     **  **  **  **  **     ** 
 ******       ***      ********  **  **  **  **     ** 
 **          ** **           **  **  **  **   **   **  
 **         **   **   **     **  **  **  **    ** **   
 ********  **     **   *******    ***  ***      ***