SoftPerfect Network Scanner

Scan in v8 is slower than in v7

Started by tonyjdaniels

Scan in v8 is slower than in v7   06 September 2021, 05:36

I upgraded from version 7.1.3 to 8.1.1 and went through all the settings (identical) and version 8.1.1 is much slower than version 7.1.3 while scanning my work's /16 supernet.

Also unable to find where to only show "active" responding IPs in the list as it's being built. 8.1.1 shows all IPs regardless of active or not.

FYI: Display inactive devices in Options - General setting is UNCHECKED.

Any advise to speed up scanning and only show "active/responding" IPs in the list while scanner is running?

SoftPerfect Support forum - Andrew avatar image

Re: Scan in v8 is slower than in v7   06 September 2021, 11:40

It's either that the settings are not exactly identical, or you found a regression. It may be some specific scan that is taking time, so I would recommend turning scanning options off one by one until you determine which one is culprit. We can then look into it.

If the Display inactive devices is unchecked, but inactive devices are still shown, it is usually because Allow ARP outside current subnet is checked and the router responds to every ARP request with its own MAC address. In this case you will see that all devices have the same MAC address. Simply uncheck this option and the software will only send ARP requests within the current subnet.

If these issues persist, please submit a support ticket and send us the relevant screenshots and your XML config file.

Reply to this topic

Sometimes you can find a solution faster if you try the forum search, have a look at the knowledge base, or check the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • Write in English. If possible, check your spelling and grammar.




A brief and informative title for your message, approximately 4–8 words:


Spam prevention: please enter the following code in the input field below.

 ********  **     **  ********  **     **   ******  
    **     **     **  **        ***   ***  **    ** 
    **     **     **  **        **** ****  **       
    **     **     **  ******    ** *** **  **       
    **      **   **   **        **     **  **       
    **       ** **    **        **     **  **    ** 
    **        ***     ********  **     **   ******