Operation failed with status code C0000098, Image header is corrupted or not accessible

Started by Pedro Santos

Hello,

I use a Auto Mount/Persistent RAM drive with 768 MB. Today when I booted I got:
SoftPerfect RAM Disk
Operation failed with status code = C0000098 and image status code = Image header is corrupted or not accessible
0 The operation completed successfully
OK

I need the data on the image, can I get it out somehow?
I have RAM Disk Version 3.4.

Thanks,
Pedro
I also have this same issue. I tried to open my ramdisk PassMark OSFMount with offset of 4096 bytes but it does not open, How ever it does open my other ramdisks, I am left thinking that it's somehow corrupt itself to the point of unable to being opened again, I do need some data off of it, if there's any solution it'd be great. Thanks.
Same for me at 3.4.2
Win 8.1 x64
4.5Gb ram disk

After that error my SVI file doubled and have 8+Gb
and can not be open
More likely, for some reason your image file size had grown twice, and after that became unmountable. We have received a few reports where image file grew in size, but it's highly unlikely through the normal operation of the RAM Disk software. Quite possibly it's a result of a conflict with third-party software.

Could you please list what other software you have installed on this computer? Especially applications that might filter file operations, like antivirus and security software.
Windows Defender (included in Win8.1), Outpost Firewall Pro.
Some big programm packets: Razer Synapse 2, Logitech SetPoint, Nvidia drivers.
We seem to have found the bug, but could anyone who experienced image file size growth please confirm the following:

1. You had set up the RAM disk to periodically save data to an associated image file.

and/or

2. The image file became corrupted after the system had been restarted or turned off/on.

Thank you.
Andrew,
1. "Save Contents to Image"- ON,
in advanced "Save contents to associated image every, min" - OFF
2. Yes, corrupted after restart pc
It appears to have been caused by CCleaner. If you have it installed, it's the answer to what damages the image file files.
I encountered the same problem.

Save Contents to Image - checked. Save contents to associated image every, min - 5
My image is just 6 GB but it seems have grown to 9 GB.

Is there any way to recover the data on the image or is it impossible?
VD

Re: Operation failed with status code C0000098, Image header is corrupted or not accessible   28 April 2014, 11:56

Juan, do you have CCleaner software on this system?
Hi, folks!
I got that C0000098 error today. The disk was created using an image file with a size of 8 GB (raw). The image file's size now is 12,2 GB.

I changed some Windows settings yesterday and maybe that had an influence:
- Enabled services "Superfetch" and "Disk Defragmenter" and set their startup type to "Automatic" (both were stopped and disabled)
- Changed value of registry key "EnableBootTrace" from 0 to 3

Marzl
Has anyone figured out how to fix this yet?

My own experience with this issue: I created a 3GB disk, and had it set to save every 5 minutes. I got this error, and was confused, so I looked it up and found this thread. I went back to the file and noticed that it now registers 3.03GB
SoftPerfect Support forum - Andrew avatar image

Re: Operation failed with status code C0000098, Image header is corrupted or not accessible   26 March 2016, 12:19

It' unclear what causes this issue. I can only recommend to backup your image files regularly or avoid using them at all and use a file-level backup of a RAM Disk instead with Robocopy or Unison.
Hi, I've got a similar problem.
Ramdisk fails to load an image after reboot. It happens only to one ramdisk, the other works well. It also happens every time I un-mount it and then try to mount it again.
It only happens to images created using Image Type: Hard Disk (and not volume), with hard disk emulation flag enabled. Image size doesn't change (2GB).

I have the "save to image" flag, and the "save periodically" flag (20 mins).

I do backup my files using a file copy, but it is a pain to rebuild the disk everytime, and I've also lost some files because I can't do a continuous backup.

Maybe this will help you to find and fix the bug. It would be great if RamDisk could cycle image between 2 files, so if one gets corrupted there always is a working copy.
I faced this issue 2 days ago on Windows 10 when I started my PC. Image size increased. Original disk size was 300MB. Periodic save is turned on.
Couldn't mount it with OSF mount with offset, I mean it didn't show any filesystem on it, and recovery programs can't help at all. All datas RIP! sad
Perhaps a built in backup function could be helpful if the bug can't be resolved?
SoftPerfect Support forum - Andrew avatar image

Re: Operation failed with status code C0000098, Image header is corrupted or not accessible   01 October 2016, 16:57

I am sorry that you lost your data, but we've been unable to determine what causes this.
It may be a good idea to instead use a volatile RAM Disk with a third-party backup tool.
It worked for months without any problems. But one thing that I found is that I turned on a scheduled disk cleanup before on all drives. I don't remember any other changes, so most likely the disk cleanup caused this.
This happened to me first time in almost 10 years after trying to install kb4534310. Has anyone found the way to restore the data? I've checked the hex and there's readable data.
SoftPerfect forum:
Quote

If the RAM Disk app refuses to mount it, try a third-party disk mount utility that supports entering an offset, like OSFMount, in which you need to enter the offset of 4096 bytes to the data when mounting the image file. An image file is essentially a 4K header followed by raw disk data.

Ok, I was able to mount it with osfmount_x64_v2_0_1001 with the offset of 4096 bytes and restore the data. One folder was clearly damaged. Thank you
SoftPerfect Support forum - Ann avatar image
Ann

Re: Operation failed with status code C0000098, Image header is corrupted or not accessible - Solved   30 January 2020, 15:03

I am glad to hear that mounting with an offset helped in your case. Thank you for letting us and other users know.

Unfortunately, this issue manifests occasionally, and its cause is still unknown. It happens very rarely, but nevertheless... Mounting the affected image file with an offset using a utility like OSFMount still seems to be the best option for trying to salvage the data.

Reply to this topic

Sometimes you can find a solution faster if you try the forum search, have a look at the knowledge base, or check the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • Write in English. If possible, check your spelling and grammar.

Author:

Email:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

 **      **  ********   *******   **        **    ** 
 **  **  **  **        **     **  **         **  **  
 **  **  **  **               **  **          ****   
 **  **  **  ******     *******   **           **    
 **  **  **  **               **  **           **    
 **  **  **  **        **     **  **           **    
  ***  ***   ********   *******   ********     **    

Message: