Weird things happening with large RAMDisk

Started by doveman

Weird things happening with large RAMDisk   16 June 2013, 03:05

I've got 16GB and have been using a 11GB RAMDisk to hold most of Arma2CO's files. After loading the RAMDisk, I still have about 2800MB free and ArmA can only use 2GB anyway.

However, in-game, if not immediately then certainly after a while, I start getting stuttering constantly. When I go to close the game, it takes ages to shutdown, much longer than if I wasn't using a RAMDisk and after the games shutdown, my HDD is churning away for 15-20mins and my system is quite unresponsive. I tried using Process Monitor to identify what was accessing the HDD but couldn't really see.

When ArmA is running, Task Manager tends to show around 1000MB available and 0MB Free (but I understand the latter isn't particularly important, at the moment I'm not using the RAMDisk and it shows 12300MB Available and 96MB Free).

I wonder if, instead of using the available RAM, the game is for some reason loading into and running from the pagefile, although even then I'm not sure it should take so long to close and doesn't seem to explain the HDD activity after closing the game.
SoftPerfect Support forum - Andrew avatar image

Weird things happening with large RAMDisk   16 June 2013, 04:28

What are you using the RAM disk for? Have your stored your game files there or something?

So far it sounds that the game struggles with running with little memory left to it as the RAM disk takes up the most of it.

Weird things happening with large RAMDisk   16 June 2013, 05:08

Yeah, I've got the Arma2CO data files on the RAMdisk, so they're streamed from there and not the HDD for faster loading and to prevent stuttering in-game.

As I said, ArmA can only use 2047MB max and there's around 2800MB free before I launch it and when I've checked, Task Manager was showing around 1000MB free with it running.

There's also the issues of ArmA taking ages to close and the HDD thrashing for a long time after it's been closed.

Weird things happening with large RAMDisk   18 June 2013, 04:03

if your HDD is thrashing then although Arma2CO can only use 2gig it sounds like windows or drivers are using more than the amount of ram left. Task manager doesn show the ram used by drivers and other stuff.

Weird things happening with large RAMDisk   18 June 2013, 04:22

Even if Task Manager doesn't show the RAM used by drivers, surely the Available ram as shown there and in RAMDisk reflects this and doesn't show 2800MB Available if drivers, etc are actually using 1000MB of this and really only 1800MB is available?

So before I load ArmA, there's 2800MB Available and when it's running about 1100MB Available. I can't imagine drivers or windows suddenly gobbling this all up for no reason. It does seem that even though there's all this RAM available, Windows is pushing stuff (probably ArmA considering how long it takes to close) into the pagefile and running it from there, although I'm still not sure why the HDD would be thrashing for 10-15mins after ArmA is closed. I guess I could try disabling the pagefile, although I imagine things will start crashing!

If I use a 8GB RAMDisk, obviously with less of the ArmA files on, then I don't experience this problem. It would be better if I could use a 11GB RAMDisk though as then less files need to load from HDD. For DCS BS2, it needs to be about 10.5GB to fit everything in and that's just for the BS2/KA-50 module (I'm using some mods but mostly they replace files and probably contribute about 500MB at most).

Weird things happening with large RAMDisk   26 June 2013, 09:10

Had two weird things today.

First I tried disabling the pagefile, to eliminate that as the cause of the HDD thrashing.

I had about 13.5GB free before mounting my 8GB RAMDisk, about 5.5GB free after. After playing ArmA2 for a while, it froze and I had an error on my desktop saying that there was insufficient RAM (or perhaps virtual ram/swapfile and it needed more than 5MB or something). Checking Task Manager showed that there was still around 2GB available (A2 can only use a max of 2GB) so there was plenty of RAM free.

Then I re-enabled the swapfile and rebooted. This time, after a while I alt-tabbed out of A2 and Task Manager (and SoftPerfect) showed 5301MB available (as before, I had about 5.5GB free before loading A2) and 678MB free (4770MB cached) which would mean ArmA was barely using anything. The Processes tab showed that arma2oa.exe was using 183MB Working, 176MB Private Working Set and 1030MB Commit Size.

Reply to this topic

Sometimes you can get the answer faster if you try the forum search and/or have a look at the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • If possible, check your spelling and grammar.

Author:

Email:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

  ******   ********   **     **  ********   **     ** 
 **    **  **     **  **     **  **     **  ***   *** 
 **        **     **  **     **  **     **  **** **** 
 **        ********   **     **  ********   ** *** ** 
 **        **         **     **  **     **  **     ** 
 **    **  **         **     **  **     **  **     ** 
  ******   **          *******   ********   **     ** 

Message: