RAMdisk not auto-mounting after Windows Updates

Started by BrainCrash

BrainCrash

RAMdisk not auto-mounting after Windows Updates   02 October 2015, 05:52

Hi,

I have recently done a fresh install on an Intel Core i5 HP notebook, with Windows 7 HomePrem SP1 64bit OEM.
RAMdisk was one of the first programs to be installed, and worked fine, UNTIL i just installed only a few of the latests windows updates. Now, the RAMdrive does not automatically mount anymore after startup.

The problem therefore seems to be related to installing the following Windows Updates (since this is the only change after which the problem occurred). Installed on 1st of October 2015:
KB3083324
Definition update for Windows Defender KB915597 (v. 1.207.1296.0)
KB3020369
KB3077715

The GUI program does start at system startup: the RAMdisk icon is present in the systemtray. When I open the GUI, the RAMdisk is still present, just not mounted. I can still manually mount it with the mount option.

Ramdisk details:
512MB drive,
mount as B:
Created as boot-time disk (not login-time)
HardDisk Emulation enabled wink
NTFS filesystem

Any idea what the cause can be? Is there a logfile anywhere that I can check to see the status of mount-actions? (or mount-attempts?)

Thanx.
SoftPerfect Support forum - Andrew avatar image

Re: RAMdisk not auto-mounting after Windows Updates   02 October 2015, 09:12

This could be virtually anything, but usually it happens when the kernel refuses allocation of a large memory block (512 MB is not large as such, but may be a significant part of all available RAM - depends on how much RAM there is in total).

Another possibility is when you have the HDD emulation on it may take longer to mount the drive. You can try turning this option off or switch to a logon-time RAM drive.
BrainCrash

Re: RAMdisk not auto-mounting after Windows Updates   04 October 2015, 08:08

Thanx for answering!

The computer has 4GB of RAM by the way.
I fixed it in the meantime though.

What i did:
- Tried removing and re-adding the RAMdrive from the GUI using same settings: no effect, still wouldn't mount automatically.

- Uninstalled the entire RAMdisk application
- Re-installed it.
- Created a new RAMdisk, using the following settings
-- Changed drive letter from B: to R:
-- Changed filesystem from NTFS to FAT32
-- Kept size the same at 512MB
-- Kept Harddisk Emulation the same at Enabled
-- Kept type the same at Boot-Time disk

After this, it worked again. So, I'm not sure exactly what fixed it (the re-install, driveletter or filesystem change) because i did everything at once, but at least it IS fixed! Working properly now.

Reply to this topic

Sometimes you can get the answer faster if you try the forum search and/or have a look at the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • If possible, check your spelling and grammar.

Author:

Email:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

 **     **  ********  **     **   *******   ******** 
 ***   ***     **     **     **  **     **     **    
 **** ****     **     **     **         **     **    
 ** *** **     **     *********   *******      **    
 **     **     **     **     **         **     **    
 **     **     **     **     **  **     **     **    
 **     **     **     **     **   *******      **    

Message: