Data is persistent in RAMdisk although the option is not selected

Started by Gerrit


I have a ramdisk setup where there is no image file linked to the ramdisk, but when the system reboots, the contents of the disk remain. As I use this ramdisk for temporary storage (e.g. browser cache, cookies, ...) I prefer to start with a clean ramdisk. Any idea how to solve this?

BTW: where are the ramdisk configurations stored? In the registry or somewhere in a config file?
SoftPerfect Support forum - Andrew avatar image

Re: Data is persistent in RAMdisk although the option is not selected   13 October 2015, 19:32

Probably you're using Windows 8 or Windows 10. These systems feature a so-called hybrid boot. Even when you shutdown the computer, it is not a real shutdown and Windows preserves the RAM disk's contents.

You may want to either disable hybrid boot or do a full shutdown.

As to the settings
  • All settings except boot-time RAM disks are stored in a file in c:\ProgramData\SoftPerfect\RAMDiskWS.
  • Boot-time RAM Disks are stored in the registry in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\SPVVEngine\Options\Auto.
I have uninstalled the SoftPerfect RAM disk in Windows Server 2012 R2 but the RAM disk is still there everytime I boot the computer. How can i disable this auto start up of the RAM disk or totally uninstall the RAM Disk?
SoftPerfect Support forum - Ann avatar image

Re: Data is persistent in RAMdisk although RAMdisk has been uninstalled   22 October 2015, 14:22

Have you tried these steps?

Reply to this topic

Sometimes you can find a solution faster if you try the forum search, have a look at the knowledge base, or check the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • Write in English. If possible, check your spelling and grammar.




A brief and informative title for your message, approximately 4–8 words:


Spam prevention: please enter the following code in the input field below.

 ********  **    **  **     **  ********   **     ** 
    **     ***   **  **     **  **     **  **     ** 
    **     ****  **  **     **  **     **  **     ** 
    **     ** ** **  **     **  ********   **     ** 
    **     **  ****   **   **   **         **     ** 
    **     **   ***    ** **    **         **     ** 
    **     **    **     ***     **          *******