Cannot mount 4 GB RAM disk

Started by Gabriel

Gabriel

Cannot mount 4 GB RAM disk   04 December 2019, 09:28

When attempting to mount a RAM disk, I get this message:
Quote

NT Error Code = C000009A: insufficient system resources exist to complete the API, image status = Unknown reason.
Win32 error code = 0 The operation completed successfully.


I am using the latest version of RAM Disk, 4.0.9 64 bit. I have 32 GB of RAM and am only using 6 GB.
The RAM disk is exactly 4 GB.
SoftPerfect Support forum - Ann avatar image
Ann

Re: Cannot mount 4 GB RAM disk   04 December 2019, 09:32

This shouldn't be happening normally, but try creating a slightly smaller RAM Disk, i.e. 3999 MB. We received a few reports from our users about some weird behaviour in memory allocation routines around the 4 GB threshold, especially in Windows 10 update v1809.

Please let us know whether a slightly smaller disk worked for you.
Gabriel

Re: Cannot mount 4 GB RAM disk   04 December 2019, 09:35

It works now. I just tried remounting it and it worked. I didn't make any changes.

Reply to this topic

Sometimes you can find a solution faster if you try the forum search, have a look at the knowledge base, or check the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • Write in English. If possible, check your spelling and grammar.

Author:

Email:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

 ********  **     **  **    **  **     **  **       
    **      **   **   **   **   **     **  **       
    **       ** **    **  **    **     **  **       
    **        ***     *****     **     **  **       
    **       ** **    **  **     **   **   **       
    **      **   **   **   **     ** **    **       
    **     **     **  **    **     ***     ******** 

Message: