Server 2019 Core issue with .dll not found

Started by Peter


Server 2019 Core issue with .dll not found   20 May 2020, 12:52

Dear Sir/Madam,

I uninstalled Ram Disk 4.0.9 completely from my system, rebooted and then tried to install the new version 4.1.0. It came up with a series of splash screens which indicated that the installer, and then the exe file, would not execute properly because d3d10.dll was not found, then d2d1.dll, then d3d10_1.dll.

Consequently, I reformatted my drive and did a clean install of Server 2019 Core and tried to install RAM Disk again, unfortunately with the same result. Please note that I have never had these issues with earlier version of RAM Disk. I tried Microsoft's own advice to install dxwebsetup.exe to resolve the dll errors, but that won't install on Server 2019 Core.

As an experiment, I reformatted and did another clean install of Server 2019 Core and downloaded all Windows updates, then copied d3d10.dll, d3d10_1.dll and d3d10core.dll, d3d10_1core.dll from a working Windows 10 System32 and SysWOW64 folders. This results in the GUI starting but a splash screen saying initialisation of VVLIB failed. All GUI menus and buttons are greyed out. This inability to install RAM Disk has never occurred before. It seems to me that the current installer isn't installing all the correct dependencies.

Can you please help as I don't know what else to try? I need to use your RAM Disk as I run a vital program in a RAM Disk and cannot do without it.

Thank you in anticipation of your earliest response.

Yours faithfully,
SoftPerfect Support forum - Ann avatar image

Re: Server 2019 Core issue with .dll not found   20 May 2020, 15:21

Thank you for reporting this issue. It looks like the latest release introduced a Direct2D dependency, which is used for rendering vector icons and images in the application. We have just updated the RAM Disk package: now, if Direct2D is not found, it will fall back to software rendering.

To update, please follow these steps:
  1. Remove these keys from the registry (with regedit.exe), to ensure smooth installation of the update:
  2. Download the updated build from RAM Disk page (the version number hasn't changed, but the file is new).
  3. Install it over your current installation and everything should then work correctly.

Reply to this topic

Sometimes you can find a solution faster if you try the forum search, have a look at the knowledge base, or check the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • Write in English. If possible, check your spelling and grammar.




A brief and informative title for your message, approximately 4–8 words:


Spam prevention: please enter the following code in the input field below.

 ********  ********   ********    ******   ******** 
    **     **     **  **     **  **    **  **       
    **     **     **  **     **  **        **       
    **     ********   ********   **        ******   
    **     **         **         **        **       
    **     **         **         **    **  **       
    **     **         **          ******   ********