Files saved to image despite deselected "save contents to image" setting

Started by Thomas

Hello,
I'm looking for a way to set up a computer where the user profiles are getting reset to a defined state on every boot. I am testing your RAM Disk at the moment. The latest version downloaded from your website.

I am using an image file with the user profile folders in it. It is mounted as boot disk and the option "save contents to image" is NOT selected. If I understand the documentation correctly, that should discard any changes made to the RAM disk on shutdown and NOT write them to the image file.

But the image file gets updated and changes to the RAM drive are persistent. E.g. if I copy a file to the RAM drive, the file is still there after a reboot. Am I missing the point of the deselected "save contents to image" option, or is this a malfunction of the software?
SoftPerfect Support forum - Ann avatar image
Ann

Re: Files saved to image despite deselected "save contents to image" setting   25 October 2021, 11:29

Most likely, this issue is caused by one of these two:
  • Hybrid boot. If you have hybrid boot enabled (default Windows behaviour), it will keep files between sessions. Please see this article for workarounds.
  • Hard disk emulation. Try the same setup, but without hard disk emulation. I.e. create an image as a standalone volume and do NOT tick "Hard-disk Emulation" in RAM disk properties.
I can confirm it is working as expected without HDD Emulation.

The Hybrid Boot was not the reason in my case. I disabled the hiberfile.sys by default by doing a powercfg -h off. The registry key for disabling hybrid boot was also present. The "changed" timestamp of the image file was getting updated as well, so it was not an issue of the system not actually doing a reboot/sutdown.
SoftPerfect Support forum - Ann avatar image
Ann

Re: Files saved to image despite deselected "save contents to image" setting   25 October 2021, 11:46

Thank you for reporting the results. I suspect the culprit would be the Shadow Copy Service also known as VSS.

If System Restore is enabled, it might think that the user profile is crucial for system functioning and needs to be backed up. Then on next boot it realises that the user profile is missing or changed, and tries to restore it. Since Shadow Copy/VSS does NOT support standalone volumes without HDD emulation, that's likely why it works as expected when you disable the HDD emulation.

So you can either use a RAM disk without HDD emulation (or try disabling System Restore), or you could use special software called Deep Freeze that maintains a clean copy of the system between reboots.
VSS was disabled all the time during testing. So that's not what causes the image to be updated.

Thanks for the hint about Deep Freeze. But I guess the price will be over the edge for a ... let's call us a small club of computer enthusiasts.

Thanks for all your support
Thomas
Also, I was able to reproduce the issue on a very old version of my test machine too. This one was only used to store a crypto currency wallet, so no odd modifications to the setup. I've cleared a copy of that machine from everything remotely personal so I can offer it to you to for download. The basic installation is German, but I've set language and regional settings to English (Australia) so you won't be forced using a German language machine.

There is an issue that sometimes forces you to logon twice because the first logon will fail. I guess it's about the load behaviour of RAM Disk, but I'm not sure. Sometimes it happens, sometimes it doesn't.

I can put the files of that VMware machine on my OneDrive and give you a share invitation link via a private email or message.

Best regards
Thomas
SoftPerfect Support forum - Ann avatar image
Ann

Re: Files saved to image despite deselected "save contents to image" setting   02 November 2021, 10:50

We have some good news here.

First of all, thank you for pursuing this and for sending the files. You were right about the bug with disk contents being saved to image when it was not supposed to happen. It was a bug in our code, but we could not reproduce it earlier because it required a very particular series of actions that was impossible guess without the additional information you provided: 1) Create a RAM disk 2) Tick Keep Contents 3) Reboot 4) Untick Keep Contents.

Secondly, we found the case where a RAM disk occasionally would not mount on boot. This is why you were getting these logon errors as Windows was not able to find the user profiles.

You can download the latest build with these fixes. It will soon become a new release.

Reply to this topic

Sometimes you can find a solution faster if you try the forum search, have a look at the knowledge base, or check the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • Write in English. If possible, check your spelling and grammar.

Author:

Email:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

 **     **  ********    *******   **    **  ******** 
 **     **  **     **  **     **  ***   **     **    
 **     **  **     **  **         ****  **     **    
 *********  ********   ********   ** ** **     **    
 **     **  **         **     **  **  ****     **    
 **     **  **         **     **  **   ***     **    
 **     **  **          *******   **    **     **    

Message: