Running Bandwidth Manager under VMware

Started by Karnage

Running Bandwidth Manager under VMware   15 May 2015, 12:25

Has anyone had experience with running Bandwidth Manager under vmware?

I have installed BWM on a windows 8.1 virtual machine and am running it in bridge mode. The vmware ESXi server has 2 NICs and 2 virtual switches setup. vSwitch0 is connected to vmNIC0 & vSwitch1 is connected to vmNIC1. The Win 8.1 VM has 2 NICs with 1 connected to vSwitch0 & the other connected to vSwitch1. BWM is then set to bridge these to NICs with a "allow all" rule. Everything is running in the same IP range. See image below. Unfortunately nothing is being passed through.

I know this is a bit of an unusual question but was hoping someone out there had run BWM under vmware and got it working.

SoftPerfect support forum
SoftPerfect Support forum - Andrew avatar image

Re: Running Bandwidth Manager under VMware   15 May 2015, 13:19

This sounds like you need to enable Promiscuous Mode on the VMWare NICs and/or the switch. The bridging requires the NICs to operate in this mode to work.

Re: Running Bandwidth Manager under VMware   15 May 2015, 14:12

Thank you VERY much Andrew!

I have spent hours on this and after setting Promiscuous mode on both vSwitches it now allows bridging to work. Great work!

You have really helped me a lot and I really appreciate the help especially when it wasn't a actual problem with your product.

Reply to this topic

Sometimes you can get the answer faster if you try the forum search and/or have a look at the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • If possible, check your spelling and grammar.




A brief and informative title for your message, approximately 4–8 words:


Spam prevention: please enter the following code in the input field below.

 ********        **  ********   **         **    ** 
 **    **        **  **     **  **    **   **   **  
     **          **  **     **  **    **   **  **   
    **           **  **     **  **    **   *****    
   **      **    **  **     **  *********  **  **   
   **      **    **  **     **        **   **   **  
   **       ******   ********         **   **    **