"Ignore LAN traffic" setting became unchecked

Started by cdg

cdg

"Ignore LAN traffic" setting became unchecked   07 February 2016, 19:16

After installing both Networx 5.50 and 5.51, the "Ignore local traffic within the LAN" setting was UN-checked on both Windows 7 and Windows 10 machines, although it was left checked on the Windows XP machine. This meant, when the problem was discovered, adjusting the usage and peer-usage values in the database yet again. Perhaps you could fix this before the next release. Thank you
SoftPerfect Support forum - Andrew avatar image

Re: "Ignore LAN traffic" setting became unchecked   07 February 2016, 21:41

This part of the app hasn't changed for a long time. Perhaps it was something else?
cdg

Re: "Ignore LAN traffic" setting became unchecked   08 February 2016, 01:19

When it happened after installing 5.5.0 on 1/23/2016, I thought I might have accidentally unchecked the box. But when I installed 5.5.1 last night (2/06/2016), it happened again, and I KNOW I didn't uncheck the box, because I didn't enter the settings module for any reason. I note one difference (in respect to networx installation) between XP and W7/W10: in XP, right-clicking the systray icon and clicking "exit" allowed me to install the new version. In W7 and W10, I had to use task manager to terminate the networx process. This may or may not be related.

Re: "Ignore LAN traffic" setting became unchecked   08 February 2016, 03:49

W7-64 Pro, did not have your problem
The 'exit' worked
The box stayed checked

Sounds like you may have some other issue that impacts NetWorx
cdg

Re: "Ignore LAN traffic" setting became unchecked   08 February 2016, 09:23

W7 Professional 32-bit. W10 32-bit and 64-bit Build 10586.71. Same problem with all three. All three start networx at boot-time from a shortcut in the startup folder.
SoftPerfect Support forum - Andrew avatar image

Re: "Ignore LAN traffic" setting became unchecked   08 February 2016, 10:57

Quote

cdg

All three start networx at boot-time from a shortcut in the startup folder.


Are you using the portable version per any chance? The Ignore local traffic within the LAN option is not available in the portable version and is displayed as disabled in the UI.
cdg

Re: "Ignore LAN traffic" setting became unchecked   08 February 2016, 14:35

No, I'm not using the portable version, and the "ignore traffic within the LAN' check-box IS present. The problem is two-fold. 1) When I go to install a new version of networx, the installer says I need to exit from the version that is running. When I right-click click the icon and click "exit", it works with XP, but doesn't work with W7 and W10. With the latter two, I have to end the process via task manager. 2) After the new version is installed, the "ignore traffic within the LAN" check-box is unchecked. I can reproduce this every time by reinstalling 5.5 or 5.5.1. I don't know if this would happen reinstalling 5.4.2.
SoftPerfect Support forum - Ann avatar image
Ann

Re: "Ignore LAN traffic" setting became unchecked   08 February 2016, 15:18

We don't seem to be able to reproduce this problem in our environment, neither with Windows 7 nor 10. So, at present, we can't say what causes it and how to fix it, sorry.
We haven't heard from anyone else having a similar issue, though if someone complains in the future, I hope it will help us diagnose and fix this problem.
cdg

Re: "Ignore LAN traffic" setting became unchecked   08 February 2016, 15:23

ANOMALY PARTIALLY SOLVED!

1) Although "Load on Windows Startup" is checked on all four machines (WXP, W7-Pro-32bit, W10-Pro-32bit, W10-Pro-64bit), for some reason there was also a shortcut to networx.exe in the "C:\Users\...\Startup" folder for the W7 and W10 machines. (Presumably I added it some time ago, not realizing it was redundant, or that it caused other problems.) Once this shortcut was removed, clicking "EXIT" does terminate the process as well as removing the icon from the Systray. So that problem is solved.

2) I tried reinstalling networx 5.5.1 on the W10-Pro-64bit machine after removing the shortcut and rebooting. This time it did NOT uncheck the "Ignore local traffic..." option, but ...

3) The next several times I rebooted, the "Ignore local traffic..." option WAS unchecked. The fourth time, it remained checked!!!! So something strange is still occurring. sad
SoftPerfect Support forum - Ann avatar image
Ann

Re: "Ignore LAN traffic" setting became unchecked   08 February 2016, 21:29

Thank you for the information. I'm gad to hear that the "exit" problem is solved. It also explains why nobody else had the same problem.

Regarding the random state of the "Ignore LAN traffic" checkbox -- that's a mystery. As I said earlier, we couldn't reproduce it. I hope there is an explanation and/or a solution to it. In any case, if you find out what caused this issue, please let us know.

Reply to this topic

Sometimes you can find a solution faster if you try the forum search, have a look at the knowledge base, or check the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • Write in English. If possible, check your spelling and grammar.

Author:

Email:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

 **      **  **    **  **     **   *******   **      ** 
 **  **  **  ***   **  ***   ***  **     **  **  **  ** 
 **  **  **  ****  **  **** ****  **         **  **  ** 
 **  **  **  ** ** **  ** *** **  ********   **  **  ** 
 **  **  **  **  ****  **     **  **     **  **  **  ** 
 **  **  **  **   ***  **     **  **     **  **  **  ** 
  ***  ***   **    **  **     **   *******    ***  ***  

Message: