Windows 10 Networx 5.5.5 not visible

Started by Mike


Windows 10 Networx 5.5.5 not visible   01 December 2016, 12:09

Hello Everyone,

I have downloaded Networx 5.5.5 on my Windows 10 machine. The install program runs without any problems, but I do not have any taskbar icons and nothing else besides "Networx Desk Band" on the taskbar right click options under tool bars which does nothing when I click on it.

I can see Networx running on task manager but I cannot end the task, and I cannot uninstall since it tells me Networx is running and I need to shut it down, but I have no way of doing this....

I have tried clearing the icon tray cache, I killed the running Networx with a third party task killer, but it started back up and now I cannot use the task killer to stop it again.

I had to go through the registry and delete many Networx lines to finally get rid of it to reinstall but the same situation came up again...Networx running in task manager, no task bar icon, doesn't let me select the Networx Desk Band, and I cannot stop it or uninstall it....

Any help would be appreciated

SoftPerfect Support forum - Andrew avatar image

Re: Windows 10 Networx 5.5.5 not visible   01 December 2016, 14:58

I am sorry that you are having troubles with NetWorx. It works fine for most users, as well as on our test system. Unfortunately I have no idea what could be wrong in your case.

Speaking of how to uninstall it, we have an article about that - it doesn't need to be removed from the registry. Just kill the process and you will be able to uninstall it.

Re: Windows 10 Networx 5.5.5 not visible   26 December 2016, 21:21

I have exactly the same problem.
After running Networx 5.5.5 for weeks without any problems, I had to uninstall and re-install it. The problem occurred after this re-installation.

My current Windows version is 1607, Build 14393.576.

As Mike wrote before, I can see the Networx application in the Task-Manager, but anywere else and it is impossible to stop it from the Task-Manager.
Since I deactivated starting Networx at Windows start-up (Also an option of the Windows Task-Manager), uninstallation was possible after a re-start of the PC, as this finally kills Networx.
I already tried installing and running it as Admin, without any effect. I also closed all other programms during the installation.

Also trying to run it in Windows-Compatability Mode, e.g. for Windows 7 or 8, failed.

In short, I do not have any more idea, what to try to get Networx running again.

I would be grateful if there could be a solution.
SoftPerfect Support forum - Andrew avatar image

Re: Windows 10 Networx 5.5.5 not visible   27 December 2016, 19:02

I guess it's running normally, but for some reason it wasn't able to install the notification area icon.

There are generally 3 ways to access running NetWorx. Does any of these work for you?

Method 1. Use the notification area icon.

SoftPerfect support forum

Method 2. Use the desk band component. It can be enabled by right-clicking an empty space on the taskbar and choosing Toolbars - NetWorx Desk Band

SoftPerfect support forum

SoftPerfect support forum

Method 3. Use the start menu. Run NetWorx from the start menu and if it's already running, it should present its popup menu instead:

SoftPerfect support forum

Re: Windows 10 Networx 5.5.5 not visible   28 December 2016, 19:04

Dear Andrew,

Thank you for your very quick reply.
Unfortunately, none of the 3 options you described above works.
The notification area icon does not appear, neither if I run NetWorx at Windows Start up nor if I try to start Networx from the start menu. Neither does the pop up if I try to start the already running application again from the start menu. The deskband is showing NetWorx is not running, although the process is visible in the task manager.

How could I post a screenshot? I tried do decribe the problem as good as possible, but maybe it would be better if you can see it.
I tried via insert image button, but it only accepts URLs, no local path. Copy and paste unfortunately also doesn't work.

Thank you in advance.

Best regards
SoftPerfect Support forum - Andrew avatar image

Re: Windows 10 Networx 5.5.5 not visible   28 December 2016, 20:35

These symptoms suggest that NetWorx couldn't fully initialise, probably due to an external dependency. No need for a screenshot (but it can be posted by adding a link to an image if you upload it to any online image hosting site).

What about the portable version? Does it work if you unpack it into a folder and launch?

Re: Windows 10 Networx 5.5.5 not visible   29 December 2016, 19:56

Dear Andrew,

Thanks again for your kind support.
The portable version shows exactly the same behavior as the installed one. N.B: I uninstalled the latter before trying the portable one to exclude any interactions.

However, I have a virtual machine running (an older) version of Windows 10 on which no third-party software is installed. Here both the portable and the installed version are running fine.
So I guess that some other program is interacting with NetWorx on my normal system. Usually I consider this to be the antivirus Software. But since I stopped it during installation and even at NetWorx start-up, that shouldn't be the reason.

However, since the problem doesn't seem to be due to NetWorx, I guess that you cannot help me any further. If I should find a solution, I will post it here.

Thank you very much & Best regards
SoftPerfect Support forum - Andrew avatar image

Re: Windows 10 Networx 5.5.5 not visible   29 December 2016, 21:00

Thank you for offering to post a solution here if you find one. It may help some else if they have a similar issue.

Another possibility, it may be WinPCap if it is installed on your computer. Where WinPCap is installed, NetWorx will attempt to initialise it and there may be an issue related to that.
Try removing WinPCap if installed, or install WinPCap compatible with Windows 10 - there's a good chance this may solve the problem.

Re: Windows 10 Networx 5.5.5 not visible   31 December 2016, 03:57

Dear Andrew,

Thank you for the information concerning WinPCap. This was indeed the solution of the problem!
I wasn't even aware this application was installed on my PC. I uninstalled it and installed the WinPCap10 as you recommended.
Now NetWorx is running fine.

Just in case other persons have the same problem:
WinPCap was really hard to uninstall. Trying to uninstall it the normal way caused my PC to freeze. I had to start the PC in the safe mode to finally uninstall WinPCap.

Thank you very much for your support.

Best regards

Reply to this topic

Sometimes you can get the answer faster if you try the forum search and/or have a look at the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • If possible, check your spelling and grammar.




A brief and informative title for your message, approximately 4–8 words:


Spam prevention: please enter the following code in the input field below.

 **     **  ********   ********  ********   **        
 ***   ***  **     **  **        **     **  **    **  
 **** ****  **     **  **        **     **  **    **  
 ** *** **  **     **  ******    ********   **    **  
 **     **  **     **  **        **         ********* 
 **     **  **     **  **        **               **  
 **     **  ********   **        **               **