Show all posts by user

New beta version

7 years ago, by doveman in RAM Disk Forum

Haven't had any problems with the latest beta until today, when it BSOD on restarting. I'm not sure exactly when the BSOD happened as I wasn't watching, so it may have been when shutting down, during boot or after reaching the desktop. As before, the dump refers to spvve.sys. Again this is on my brother's PC, with a single 1GB FAT32 Logon Mounted RAMDisk, which is compressed to only use 12KB on

New beta version

7 years ago, by doveman in RAM Disk Forum

Hmm, it seems I had a problem with my fonts. I'm not using Firefox but this helped me fix it https://support.mozilla.org/en-US/questions/674779 It BSOD every time I tried to open Windows\Fonts or Control Panel - Fonts (or tried to search C:, which was obviously accessing Windows\Fonts), so I had to use \\PCNAME\C$\Windows\Fonts, select all 446 fonts and click Install to re-install them. I

New beta version

7 years ago, by doveman in RAM Disk Forum

I had a couple of BSOD after installing the latest version. Perhaps you could check the attached debug logs and let me know if they were related to SoftPerfect or not? I haven't had any since uninstalling it again (fingers crossed) but that might just be a coincidence. I'm wondering if it might not be playing nice with my onboard ATI graphics, which is using 256MB UMA system RAM?

New beta version

7 years ago, by doveman in RAM Disk Forum

This has been working fine on my main gaming system but on a system I'm building for my brother, I've been having some BSOD and lockups. They may not have been caused by SoftPerfect but someone analysed one of the minidumps for me and it refers to the SoftPerfect drivers, so I thought you'd like to take a look. I'll upload the dump for you to look at yourself if you'd like, just let me know. By

Weird things happening with large RAMDisk

7 years ago, by doveman in RAM Disk Forum

Had two weird things today. First I tried disabling the pagefile, to eliminate that as the cause of the HDD thrashing. I had about 13.5GB free before mounting my 8GB RAMDisk, about 5.5GB free after. After playing ArmA2 for a while, it froze and I had an error on my desktop saying that there was insufficient RAM (or perhaps virtual ram/swapfile and it needed more than 5MB or something). Check

Auto-mounting incorrectly on load

7 years ago, by doveman in RAM Disk Forum

Just had this happen again. My system ran out of RAM (it actually had 2GB free but that's a different problem which I'll post about separately), so I rebooted and when I then opened SP, the GUI didn't appear and I realised it was auto-mounting the previously mounted RAMDisk. However, it shows it's mounted three RAMDisks, which it clearly hasn't and in actual fact the only one mounted is the 800

Weird things happening with large RAMDisk

7 years ago, by doveman in RAM Disk Forum

Even if Task Manager doesn't show the RAM used by drivers, surely the Available ram as shown there and in RAMDisk reflects this and doesn't show 2800MB Available if drivers, etc are actually using 1000MB of this and really only 1800MB is available? So before I load ArmA, there's 2800MB Available and when it's running about 1100MB Available. I can't imagine drivers or windows suddenly gobbling t

Weird things happening with large RAMDisk

7 years ago, by doveman in RAM Disk Forum

Yeah, I've got the Arma2CO data files on the RAMdisk, so they're streamed from there and not the HDD for faster loading and to prevent stuttering in-game. As I said, ArmA can only use 2047MB max and there's around 2800MB free before I launch it and when I've checked, Task Manager was showing around 1000MB free with it running. There's also the issues of ArmA taking ages to close and the HDD

persistent image files

7 years ago, by doveman in RAM Disk Forum

Cool, thanks.

persistent image files

7 years ago, by doveman in RAM Disk Forum

If I have a mounted RAMDisk and edit it's properties to enable "Save Contents to Image", when I click OK it asks if I want to unmount and remount the image to save the changed setting, to which I say no. Then I unmount the image and it saves it but is this also incremental or is that only when using the "Save every x mins" option?

Weird things happening with large RAMDisk

7 years ago, by doveman in RAM Disk Forum

I've got 16GB and have been using a 11GB RAMDisk to hold most of Arma2CO's files. After loading the RAMDisk, I still have about 2800MB free and ArmA can only use 2GB anyway. However, in-game, if not immediately then certainly after a while, I start getting stuttering constantly. When I go to close the game, it takes ages to shutdown, much longer than if I wasn't using a RAMDisk and after the ga

NTFS RAMdisk size limits

7 years ago, by doveman in RAM Disk Forum

Got some info that there will be a new version of SoftPerfect RAM Disk later this year that will fix this issue.

Error C000009A

7 years ago, by doveman in RAM Disk Forum

I was getting the same error with my 10752MB RAMdisk: "One or more volumes could not be mounted. Operation failed with status code = C000009A and image status code = Image load succeeded" I wonder if it's related to the Free RAM reported in Task Manager, as I got the error and was unable to mount the RAMdisk when Available RAM was plenty (13-14GB) but Free RAM was lower, maybe 6GB or

NTFS RAMdisk size limits

7 years ago, by doveman in RAM Disk Forum

I think I was getting the same error with my 10752MB RAMdisk: "One or more volumes could not be mounted. Operation failed with status code = C000009A and image status code = Image load succeeded", but in fact it did not succeed. I wonder if it's related to the Free RAM reported in Task Manager, as I got the error and was unable to mount the RAMdisk when Available RAM was plenty (13-14

Weird results in Crystalmark?

7 years ago, by doveman in RAM Disk Forum

I've previously tested DCS World and Arma2OA with SP RAMdisk and found the loading times for both where much faster, maybe 2/3 faster. It helped with the stutter whilst flying in DCS as well, as I recall. I can't test at the moment as I get an error trying to mount my RAMdisk and I was getting lockups with Arma running from RAMdisk, although not with DCS.

Auto-mounting incorrectly on load

8 years ago, by doveman in RAM Disk Forum

Do you think you might accommodate users like myself who don't want any disks to auto-mount when launching the app? Apart from not wanting to have to remember to unmount them before rebooting/restarting, if my PC crashes (which it has done a few times lately) I obviously don't get a chance to unmount, so after rebooting and launching the app, it loads the previously mounted RAMdisk whether I wante

Auto-mounting incorrectly on load

8 years ago, by doveman in RAM Disk Forum

Yes, I understand you're saying that I need to unmount any RAMdisks before shutting down to prevent them being automatically remounted when I next launch the app. I'm saying I find that very inconvenient though and will not remember (nor do I want the hassle) to do this each time, meaning that next time I launch the app it will auto-mount a RAMdisk, which may not be the one I want to mount at that

Auto-mounting incorrectly on load

8 years ago, by doveman in RAM Disk Forum

Hmm, that's a bit bad that it auto-mounts as that means the only way I can have it so that I can choose a RAMdisk to mount after starting the program, rather than having it decide to mount whatever was last mounted without asking me, is to unmount and delete the entries from the list, which means when I want to re-mount them I have to go through "Add Disk" again, setting the drive letter

Auto-mounting incorrectly on load

8 years ago, by doveman in RAM Disk Forum

I have Softperfect RAMdisk set NOT to load on Windows startup. Normally when I start it, the GUI appears very quickly but when I just tried, it didn't appear for ages and although the systray icon appeared, it was unresponsive when clicking on it. When it did eventually appear, it shows both disks listed in the window with a green tick (i.e. mounted) both to the same drive S:, which is nonsense

Copying files to RAMdisk results in inaccessible folder

8 years ago, by doveman in RAM Disk Forum

Great, thanks. I'll definitely be using this instead of IMDisk/awealloc from now on then as it's much faster (not to mention easier to use)

Copying files to RAMdisk results in inaccessible folder

8 years ago, by doveman in RAM Disk Forum

Thanks. I compared a 10GB FAT32 RAMDisk image and a 10GB NTFS one and did find the FAT32 one a bit faster. Note my Seq and 512k results are about half what an Intel system would give as RAM runs a lot faster on those. The latest version's working nicely for me thanks. Whilst the empty FAT32 image mounted to RAM very quickly and the empty NTFS image took a long while (maybe 1min+), once

Copying files to RAMdisk results in inaccessible folder

8 years ago, by doveman in RAM Disk Forum

Ah, I see. I assumed Mount Image would mount it to a RAMDisk. When adding a disk pointing to an image it says Mounting and then has the option to Unmount, so you can see how I got confused. Using the Add Disk method and then pointing to the image, it works for a new NTFS 10GB image I created but it takes quite a while to mount. With the old image that I sent you, which is FAT32 that mounts a lo

Copying files to RAMdisk results in inaccessible folder

8 years ago, by doveman in RAM Disk Forum

Hi The last one no longer BSOD when mounting the image but it doesn't load it into RAM either, as can be seen by the fact that my free RAM doesn't go down. Running CrystalDiskMark on it gives Seq Read/Write speeds of around 80MB/s, which is the speed of the drive the image is saved on. If I create a new disk with Add without creating an image, that does decrease the free RAM by the size of t

Copying files to RAMdisk results in inaccessible folder

8 years ago, by doveman in RAM Disk Forum

No worries. I normally run in Test Mode anyway but haven't got round to enabling that since re-installing W7, so I'll do it the F8 way for now. Thanks.

Copying files to RAMdisk results in inaccessible folder

8 years ago, by doveman in RAM Disk Forum

Thanks. I tried that but when launching Softperfect after rebooting it said "Initialistation of vvlib failed" and all the buttons are greyed out in the interface.

Copying files to RAMdisk results in inaccessible folder

8 years ago, by doveman in RAM Disk Forum

Sure. I didn't think it would compress much as I thought I'd added the DCSW files to it before saving but I guess not as it's compressed from 10GB down to 11.7MB. I've uploaded it here .

Copying files to RAMdisk results in inaccessible folder

8 years ago, by doveman in RAM Disk Forum

Thanks. Sadly not though. The first thing I tried after installing was mounting the image I created previously and it BSOD with the same IRQL error again. It doesn't seem to have created a minidump I can give you this time unfortunately.

Copying files to RAMdisk results in inaccessible folder

8 years ago, by doveman in RAM Disk Forum

That's great, thanks. I'll keep an eye out for it.

Copying files to RAMdisk results in inaccessible folder

8 years ago, by doveman in RAM Disk Forum

Yes, W7 x64 Ultimate.

Copying files to RAMdisk results in inaccessible folder

8 years ago, by doveman in RAM Disk Forum

I tried again with NTFS first and whilst copying 9.45GB data, it got down to 1.6GB to go before failing with "Error 0x80070570: The file or directory is corrupted and unreadable" Then I tried FAT32 and was able to copy the files to it OK but I'm unable to run the game from it and strange things happen (basically it crashes before loading). I was able to run the game from the RAMdisk