SoftPerfect Network Scanner

Scan results show no open ports

Started by tgh-adfabre

Scan results show no open ports   10 December 2016, 02:46

I am a CIS student writing a final paper. This is the first time I have attempted anything like this. I scanned my home Wi-Fi with the demo Network Scanner. The results came back with my devices (I corroborated the results with my routers connected devices tool), MAC addresses, IP Addresses and IPv6 addresses. The results came back with no open ports, this is not surprising. I have no gaming needs or any devices that need an assigned port.

In the interest of doing a thorough paper I decide to intentionally open a port and attach it to my computer. If I leave it open long enough to scan for it, screen capture the results and close it I am good to go.
I have opened 2 FTP ports and associated them to my PC in my routers Firewall settings. I then scanned with Network Scanner and I am not picking up open ports.
I have confirmed in Network Scanner->Options->Program Options->Ports Tab:
I have the ports I opened selected to scan with about 10 others. I also selected 6 UDP port options on the lower half of the tab.

In my firewall settings I have turned off Port Scan Protection, I honestly do not think it will help but I am grasping at straws.
My first assumption is user error.

I am hoping someone here can point me in the right direction.

SoftPerfect Support forum - Andrew avatar image

Re: Scan results show no open ports   10 December 2016, 08:52

It would help if you provided some screenshots of the Ports tab as well as the scan result (e.g. you could have entered the port numbers incorrectly).

If I attempt to scan the office LAN for all ports 1-65535, the app produces something like this:

SoftPerfect support forum

Re: Scan results show no open ports   10 December 2016, 09:38

Thank you for your response.
1) The port range is from my router.
2) The devices found match the devices shown in by my router.

The first image is my PreScan Screen.
The second image is my selections in Options->Program Options->Ports Tab
The third image is my scan results.

I am wondering if I did something wrong opening the port but it is a very straight forward process in my router interface.

How did you insert an image directly? I can only find URL inserts.

Thank again.
open | download – PreScan Screen.png (25.1 KB)
open | download – Ports Selected.png (19.9 KB)
open | download – Scan Results.png (55.1 KB)
SoftPerfect Support forum - Andrew avatar image

Re: Scan results show no open ports   10 December 2016, 10:37

Hmm, now I am not quite sure what you are doing and what it has to do with the router?

In order to open a TCP or UDP port on a computer, you need to run a corresponding program that listens to that port. For example, installing and running a web-server opens port 80, FTP server opens ports 20 and 21 and so on. It's not really related to any settings done at the router. For instance, you can see what ports are open on your computer by executing the following command in a command prompt:
netstat -na | findstr LISTEN
The fact that a port is open doesn't mean it's accessible as a firewall installed on the same machine may be blocking incoming packets to all or certain ports.

For a start I'd advise to scan your local IP address (the IP address of the computer where you have Network Scanner) and a port range of 1-65535. This may take a few minutes and should report some open ports, similar to those produced by the above command.

As to inserting images in a message body here, you'd need to upload it to any image hosting service like Postimage.

Re: Scan results show no open ports   10 December 2016, 12:10

Thank you.

I am not trying to open one on my computer. I m trying to open a port on my network. That is why I am interacting with the router.One of the issues we have discussed in this course is open ports on networks and the security problems they represent.

In my router there is a NAT screen that allows opening of ports for numerous applications. Most of the list is video games because game consoles often need outbound and inbound communication. My firewall is on my router so setting the opening in the firewall at the router opens the port for use behind the firewall.

It seems like the missing component may be something on my device to use the port. I could DL the FileZilla server software and open an FTP port.

Thank you again for the response.
SoftPerfect Support forum - Andrew avatar image

Re: Scan results show no open ports   10 December 2016, 14:12

What you are doing is called port forwarding, i.e. allowing certain devices in the LAN, that would otherwise be hidden behind NAT, to receive incoming connections from the Internet.

It doesn't really open any ports on those devices and won't appear in Network Scanner. Furthermore, if you scan your network from within the LAN, those settings have no effect. Port forwarding only applies to incoming packets from the Internet and forwards packets to configured ports to specified LAN devices.

Re: Scan results show no open ports   11 December 2016, 01:37

Thank you for your responses. Being a rookie I did not understand the difference between scanning inside and outside, I also did not understand the need for a service or device using the port. I spoke with my instructor and he gave me a solution that is much simpler than the one I came up with.

Thanks again,
SoftPerfect Support forum - Andrew avatar image

Re: Scan results show no open ports   11 December 2016, 10:23

No worries, good luck with your paper! wink

Reply to this topic

Sometimes you can find a solution faster if you try the forum search, have a look at the knowledge base, or check the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • Write in English. If possible, check your spelling and grammar.




A brief and informative title for your message, approximately 4–8 words:


Spam prevention: please enter the following code in the input field below.

  *******   **    **  **    **  ********  **     ** 
 **     **  **   **    **  **   **        **     ** 
 **         **  **      ****    **        **     ** 
 ********   *****        **     ******    ********* 
 **     **  **  **       **     **        **     ** 
 **     **  **   **      **     **        **     ** 
  *******   **    **     **     **        **     **