SoftPerfect Network Scanner

How to get management information (ILO, iDRAC, IMM)

Started by Andreas


How to get management information (ILO, iDRAC, IMM)   08 March 2019, 11:20

Dear SoftPerfect Team,

Is it possible to get the ILO IP address from HP, the iDRAC IP address from Dell, or the IMM IP address from IBM with your Network Scanner tool?

Could you please help me with this question?

SoftPerfect Support forum - Ann avatar image

Re: How to get management information (ILO, iDRAC, IMM)   08 March 2019, 11:37

It should be possible. The newer implementations of ILO and iDRAC are based on the so-called Redfish API, which is essentially an HTTP-JSON interface.

Below is a screenshot of Network Scanner's Remote JSON for extracting ILO IP address. There should be a similar way for iDRAC and IMM. You can use the Redfish query builder to explore the JSON tree and find in what node the IP address is.

SoftPerfect support forum

Re: How to get management information (ILO, iDRAC, IMM)   14 March 2019, 13:34

Look under Remote XML. iDRAC is listed there. -WS

Been trying to pull info from some Dell iDRAC servers using Redfish and no matter what I try it just get the same error over and over.
I get the response in the browser fine, any thoughts?

SoftPerfect support forum
SoftPerfect Support forum - Andrew avatar image

Re: How to get management information (ILO, iDRAC, IMM)   26 September 2019, 12:14

It looks like your server expected a valid OData-Version header in the request, which the app did not send. It's strange it worked in the browser though.

Kindly try the new build that sends this header and let me know if it helped.
Tried and no good unfortunately.
Anything else you think I could try?
if I go to /redfish it gives back V1: /redfish/v1/
If I try /redfish/v1/ or anything deeper it returns "error.code 12" as before
If it makes a difference, tried on both Windows 10 and Windows 2008R2 with same results
and to Dell iDRAC
SoftPerfect Support forum - Andrew avatar image

Re: How to get management information (ILO, iDRAC, IMM)   27 September 2019, 12:51

Hmm, apparently there is some other difference between what Chrome sends and what Network Scanner sends.

We'd really like to get to the bottom of this, if you are willing to help us with that. The best way would be getting some form of access to this server, i.e. via Team Viewer or /redfish/v1/ accessible via a public IP address. Granted that may not be possible, please try running the following commands and capture their output.
curl -v -L --insecure https://{ip-address}/redfish/v1/
curl -v -L --insecure https://{ip-address}/redfish/v1/Sessions/
It's probably best to continue this investigation in a private support ticket.
No problem, I opened a support ticket.
Sorry for the late reply, the Network Scanner update published on 27 September works perfectly:

SoftPerfect support forum


Reply to this topic

Sometimes you can find a solution faster if you try the forum search, have a look at the knowledge base, or check the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • Write in English. If possible, check your spelling and grammar.




A brief and informative title for your message, approximately 4–8 words:


Spam prevention: please enter the following code in the input field below.

 **     **  **     **  **         **        **    ** 
  **   **    **   **   **    **   **        ***   ** 
   ** **      ** **    **    **   **        ****  ** 
    ***        ***     **    **   **        ** ** ** 
   ** **      ** **    *********  **        **  **** 
  **   **    **   **         **   **        **   *** 
 **     **  **     **        **   ********  **    **