'Argument out of range' error

Started by Mick


'Argument out of range' error   02 July 2021, 10:04

Hi team,

A few months ago I went from a very long term user of the old freeware version of NetScan (v6.2.1) to a purchased copy of NetScan v8.0.1. In doing so, I copied across my v6 netscan.xml file and all appeared to work fine. Until, after a random period of time (usually 20+mins) running a LiveDisplay, NetScan showed 'argument out of range' error.

If I run fresh NetScan without importing my old config, the error no longer occurs. So I assume something in my old config was causing the error.

Today I noticed in the NetScan change log "Fixed: configuration file import from version 6.x." and was hopeful upgrading would fix my issues. So I installed a fresh NetScan, copied across my v6 netscan.xml file, and all appeared to work fine. Unfortunately after ~25mins the same error appeared.

Can you suggest anything I can do to further troubleshoot this issue please? I obviously don't want to have to re-create my customised (over many years) config from scratch.

Your help would be greatly appreciated.

SoftPerfect Support forum - Ann avatar image

Re: 'Argument out of range' error   02 July 2021, 10:12

Thank you for the report. This sounds like some kind of a race condition or a bug that occurs in a rare combination of factors and settings.

We prepared this debug build for you to run, which will provide more details when this error occurs, allowing us to identify and fix it.

Once this 'argument of our range' error happens again, it will display detailed call stack information. Simply send us a screen shot of that message. It should shed some light on where the error occurs.

Re: 'Argument out of range' error   02 July 2021, 11:27

I ran a copy of this, it had "crashed", but I didn't specifically see the 'argument out of range' error this time. Does this look related?
SoftPerfect Support forum - Ann avatar image

Re: 'Argument out of range' error - Fixed   02 July 2021, 12:23

Yes, thank you, it does look right. There was a race condition, as we suspected. We have just fixed it. Please download the latest build and give it a go.

Re: 'Argument out of range' error - Fixed   03 July 2021, 16:36

Thanks again. I've been running a scan overnight, and so far so good with new version. I'm pretty sure it would have crashed by now if it were going to, so I think it is fixed.

Reply to this topic

Sometimes you can find a solution faster if you try the forum search, have a look at the knowledge base, or check the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • Write in English. If possible, check your spelling and grammar.




A brief and informative title for your message, approximately 4–8 words:


Spam prevention: please enter the following code in the input field below.

 **         ********   ********   **      **  ******** 
 **    **   **     **  **     **  **  **  **  **       
 **    **   **     **  **     **  **  **  **  **       
 **    **   ********   ********   **  **  **  ******   
 *********  **         **         **  **  **  **       
       **   **         **         **  **  **  **       
       **   **         **          ***  ***   ********