Image saving failed

Started by zer09

Image saving failed   03 May 2015, 19:58

Good day to all,

First of all I would like to ask if there is a setting in softperfect ram disk to delay the mounting of drive for a several seconds?

Actually I am new in ram disk (about more than a month), and I did a research in google what is the best ram disk and it pointed here (i also test others ram disk software), and it was true and I am happily using your product.

For now i have 2 disk mounted with ram disk with 1.5gb and 1gb, the later is a permanent while the former is not.

Now I face a problem after restarting my laptop after a few days without turning off (basically put my laptop in standby mode if not working).

Here the story,

a month ago i set up a permanent drive ram disk with 2gb capacity and saving it to my C drive, and i was very happy with it laugh. but in the last few days i reconfigured the ram disk removing the 2gb (i backed it up), and creating new 2 disk with 1.5gb and 1gb (see above), and putting the image file to my second hdd. first i notice booting with an image file in second hdd, takes time. so i tried to research if there is an option to delay the mounting of ram disk, but found nothing. so what I did next is create a task in task scheduler and let it mount the drive 2 seconds after the user logged-on and it was successful.(this is what i want laugh).

here is my setting of the task,
action: "C:\Program Files\SoftPerfect RAM Disk\ramdiskws.exe" /mount:e
trigger: at log on of my account
sec. option: run only when user is logged on(my account as administrator)
run with highest priv. and hidden.

i also have second task to close completely the gui
taskkill /im ramdiskws.exe

I test everything if it is working will and it is except that there something I didn't see.

I few moment ago restarted my laptop, after the drive is mounted navigate to the folder i worked on and see ohh my work is lost (actually my files rolled back a few days, and it is so hard to write those lines of codes again sad ).

So I investigate the issue on what happen, so i came up with this, disable the second task, rebooted, open the gui tried to unmount the drive E: and give an error that it cant be dismounted because another user is using it, then tried to save the image file and it says "Saving image failed 32 The process cannot access the file because it is being used by another process", i also tried rebooted without closing the gui and give me same message after reboot, so what happen is the image file is not save after I reboot(how sad).

I also tried disable the two task and rebooted, open the softperfect ram disk and see the non permanent drive is already mounted, then manually mounted the second ram disk try to save it and unmount it and it was successful, and try to enable the first task rebooted and the result with error again.

so everything goes wrong if i used task scheduler to mount the ram disk drive.

now here is my question, while ram disk is triggered with task schedule
why it will failed to save the image?
and unable to unmount it?

then i would like to ask if i can mount a ram disk automatically just a few second after the user logged-on not in windows start up?

I will appreciate for any help, will come.
thank you,
SoftPerfect Support forum - Andrew avatar image

Re: Image saving failed   03 May 2015, 23:01

Unfortunately I am not sure why it's failing in your case. Furthermore, I recommend not to use the image files and use a volatile RAM Disk.

You could populate the RAM Disk on startup with your own files, and backup them periodically or at logoff. For your scenario a good solution might be the Windows built-in Robocopy or Unison. Both tools only copy changed files and do so efficiently.

Better yet, get an SSD and only use the RAM Disk for temporary files. For example, we use it here to store temporary files produced by a compiler and it works well.

Re: Image saving failed   03 May 2015, 23:34

Thank you very much for your advice, and I will try it.

Re: Image saving failed   04 May 2015, 00:08

BTW one more question, can i create a volatile ram disk with disk permission applied after mounted on boot up?
SoftPerfect Support forum - Andrew avatar image

Re: Image saving failed   04 May 2015, 07:57

Just run CACLS after the RAM disk is mounted.

Re: Image saving failed   05 May 2015, 12:31

Thanks a lot

Sometimes you can get the answer faster if you try the forum search and/or have a look at the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • If possible, check your spelling and grammar.

Author:

Email:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

 **     **  **     **  ********  **     **   *******  
  **   **    **   **      **     **     **  **     ** 
   ** **      ** **       **     **     **  **     ** 
    ***        ***        **     *********   ******** 
   ** **      ** **       **     **     **         ** 
  **   **    **   **      **     **     **  **     ** 
 **     **  **     **     **     **     **   *******  

Message: