Whitelisting not working

Started by Korey Krugel

Korey Krugel

Whitelisting not working   06 January 2024, 02:35

New to the product, but not new to technology, etc. Found something that I am not able to resolve. I use VMWare workstation, and am not able to get the whitelisting working. Every time I reboot, VMWare assigns new MAC addresses, and I do not want to deal with trying to make these static.

I have tried entering the MAC address "partial match" a number of different ways, but every time I reboot my host, WiFi Guard barks at me with these new "new" unknown mac addresses. Does the whitelisting by MAC address not actually work as expected?

I have tried XX:XX:XX and XXXXXX and neither seem to work.
SoftPerfect Support forum - Andrew avatar image

Re: Whitelisting not working   08 January 2024, 14:40

Thank you for reporting this issue. We have identified and fixed the bug where adding a MAC address prefix for partial matching did not automatically recognise previously discovered MAC addresses as known.

Please download the new build and re-enter the first three octets of the MAC addresses you wish to whitelist.
Korey Krugel

Re: Whitelisting not working   15 January 2024, 04:42

The issue persists. Below is a link to the screenshot. Please let me know if I am doing something incorrect.

SoftPerfect support forum
SoftPerfect Support forum - Andrew avatar image

Re: Whitelisting not working   17 January 2024, 11:26

Apologies, it appears that even though the list of known devices was updated with a partial match, it wasn't saved. Consequently, after a reboot, WiFi Guard would identify these addresses as unknown once more.

We have recently resolved this issue. Please download the latest build, dated January 17, and re-enter the partial MAC address. This means you should delete the existing entry for VMWare and add it again.
Korey Krugel

Re: Whitelisting not working   21 January 2024, 10:27

This is crazy. The issue is still happening. The only way it works is after the scan where the MACs show up as offending is if I open up the whitelisting tab and uncheck the "automatically mark locally..." and then check it again. When I do that, they go green, but it is not happening after a reboot and after the next scan. Seems there is still more work to do here guys.
SoftPerfect Support forum - Andrew avatar image

Re: Whitelisting not working   22 January 2024, 10:21

That is indeed odd. Could you please send us the database file?

To do so, follow these steps:
  1. Press Win + R and open %APPDATA%\SoftPerfect
  2. Compress the WiFi Guard folder into a ZIP file
  3. Submit it to us using this form
We will then review it and hopefully determine the issue.
Korey Krugel

Re: Whitelisting not working   25 January 2024, 05:00

It's been 2 days. Just wondering if you received my upload with my settings.
SoftPerfect Support forum - Andrew avatar image

Whitelisting not working - Fixed   25 January 2024, 07:46

Yes, we have responded to you via the same facility where you uploaded the files. But perhaps you haven't received or missed the notification email.

The file with your settings helped us to find another edge case where the partial MAC address matching would not work. Please download the new build dated 23 January and let us know how it works for you.
Korey Krugel

Re: Whitelisting not working - Fixed   27 January 2024, 00:36

My apologies. I did miss that message. After installing the latest and rebooting, it looks like the issue has been resolved.

Thanks again for the quick turn around and attention to this. Keep on making these awesome products!

Reply to this topic

Sometimes you can find a solution faster if you try the forum search, have a look at the knowledge base, or check the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • Write in English. If possible, check your spelling and grammar.

Author:

Email:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

  *******   **    **  **     **  **     **  **     ** 
 **     **  ***   **   **   **   **     **  ***   *** 
        **  ****  **    ** **    **     **  **** **** 
  *******   ** ** **     ***     **     **  ** *** ** 
        **  **  ****    ** **     **   **   **     ** 
 **     **  **   ***   **   **     ** **    **     ** 
  *******   **    **  **     **     ***     **     ** 

Message: