Network traffic discrepancy between NetWorx and NetGenius

Started by skottmckay

Network traffic discrepancy between NetWorx and NetGenius   20 January 2022, 09:23

Currently seeing a big discrepancy between NetWorx and NetGenius on my laptop. I was installing Visual Studio so the download rate indicated by NetWorx is correct. NetGenius isn't showing that traffic at all. Is there some setting that is off that would result in this behaviour?
Attachments:
open | download – Screenshot 2022-01-20 091924.png (73.3 KB)

Re: Network traffic discrepancy between NetWorx and NetGenius   20 January 2022, 09:35

Just installed the latest version of NetGenius and now they're in sync, so probably a transient issue that may be hard to reproduce.
SoftPerfect Support forum - Andrew avatar image

Re: Network traffic discrepancy between NetWorx and NetGenius   20 January 2022, 11:42

It's okay to use NetWorx and NetGenius together, but make sure the Ignore LAN traffic option is not enabled in NetWorx. It uses a monitoring method similar to that in NetGenius, so they may conflict occasionally.
Hello,
I have both NetWorx and NetGenius installed on my computer. Right now they are opened on my task bar next to each other, but NetGenius is not showing the same download and upload speed that NetWorx is showing. Is there something wrong with my NetGenius settings? I am using the latest free trial versions for both.
For example I am using utorrent and it's showing way lesser download speed than it actually is.

Regards,
Karam
SoftPerfect Support forum - Ann avatar image
Ann

Re: NetGenius shows different download and upload speed compared to NetWorx   13 June 2022, 09:23

It depends on how you have configured NetWorx. If it is set to ignore LAN traffic and monitor apps, it may interfere with NetGenius monitoring.

If you want to use both NetWorx and NetGenius at the same time, then NetWorx should be monitoring your network adapter rather than apps. Specifically, this means:
  • In NetWorx v6 and below, the "Ignore local traffic within the LAN" option must be unchecked.
  • In NetWorx v7 and above, the monitoring mode must not be set to the monitoring of applications.

Another reason for a large discrepancy could be in that one product on your computer is configured to display data in bytes/s while the other one is configured to display data in bits/s. In this case, the difference will be 8 times. Please check the settings in both products and make sure that they are set to the same units.

Reply to this topic

Sometimes you can find a solution faster if you try the forum search, have a look at the knowledge base, or check the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • Write in English. If possible, check your spelling and grammar.

Author:

Email:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

       **   ******   **     **   ******   **     ** 
       **  **    **  **     **  **    **  ***   *** 
       **  **        **     **  **        **** **** 
       **  **        **     **  **        ** *** ** 
 **    **  **        **     **  **        **     ** 
 **    **  **    **  **     **  **    **  **     ** 
  ******    ******    *******    ******   **     ** 

Message: