SoftPerfect NetWorx

Graph looks jagged when monitoring OPNsense router

Started by Blaine

I've been using and enjoying NetWorx for many years now. It's wonderful software.

My primary use case is to monitor the WAN traffic on my router (OPNsense) via SNMP with the Windows taskbar graph. This worked perfectly with pfSense, which I used for many years. I have since switched to OPNsense and the SNMP monitoring seems to "flap", especially when my WAN connection is heavily utilized.

I can have a WAN transfer moving at a steady 2Gbit/s, but NetWorx will show this traffic bouncing wildly. Please let me know if there are any logs or additional info I can provide that may help diagnose the source of this issue.

This is a picture showing a download/upload speed test that ran at a fairly constant rate but the graph is very jagged not reflecting reality.

SoftPerfect support forum


SoftPerfect Support forum - Ann avatar image

Re: Graph looks jagged when monitoring OPNsense router   30 March 2024, 14:32

Likely, this happens because updates to the ifInOctets and ifOutOctets occur less frequently. Although I am not certain of the default update interval, it has been identified as approximately 3 seconds by some OPNsense users. Consequently, the data counters only refresh every three seconds or so, leading to a jagged appearance in the graph.

While adjusting the update frequency directly may not be straightforward, an alternative approach involves configuring the averaging period in NetWorx to a higher value. Within NetWorx hidden settings, there is a parameter named 'Mean Samples'. Setting this parameter to 10 or more can result in a graph that is less reactive but smoother.
Thank you very much for the help! This was enough info to send me down a rabbit hole to get this resolved.
For your future knowledge, just in case it comes up again. I had installed the Net-SNMP plugin in OPNsense (believing this was required for SNMP to work at all in OPNsense). No amount of fiddling with Net-SNMP was able to resolve this. It's probably possible, but I gave up.

OPNsense also ships with BSNMPD installed with a basic generic config. I disabled Net-SNMP and enabled BSNMPD following the documentation here:

I also experimented with uncommenting the following lines in the BSNMPD configuration file located at /etc/snmpd.config
# Force a polling rate for the 64-bit interface counters in case
# the automatic computation is wrong (which may be the case if an interface
# announces the wrong bit rate via its MIB).
begemotIfForcePoll = 2000
I changed the stock begemotIfForcePoll = 2000 to begemotIfForcePoll = 1000. This did not seem to make a significant difference.

Anyways, issue solved. NetWorx now works wonderfully with the default "Mean Samples = 5"

Thanks again,

Reply to this topic

Sometimes you can find a solution faster if you try the forum search, have a look at the knowledge base, or check the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • Write in English. If possible, check your spelling and grammar.




A brief and informative title for your message, approximately 4–8 words:


Spam prevention: please enter the following code in the input field below.

 ********   **               **  ********   ********  
 **     **  **    **         **  **     **  **     ** 
 **     **  **    **         **  **     **  **     ** 
 ********   **    **         **  **     **  **     ** 
 **         *********  **    **  **     **  **     ** 
 **               **   **    **  **     **  **     ** 
 **               **    ******   ********   ********