How to stop "the app you're trying to install isn't a Microsoft-verified app" pop-up

Started by Lukas

Hi everybody,

I am very happy with WiFi Guard, but I have a problem on Windows 10 Home. Each time I start the app Windows shows this message:
Quote

Die App, die Sie installieren möchten, ist keine von Microsoft geprüfte App (German)
The app you're trying to install isn't a verified app from the Microsoft Store (English translation)

I click Trotzdem installieren / Install anyway, and it works, but next time I get the message again.

Is there a way to get rid of this annoying Windows 10 warning or disable it somehow?
SoftPerfect Support forum - Ann avatar image
Ann

Re: How to stop "the app you're trying to install isn't a Microsoft-verified app" pop-up   30 June 2020, 20:40

"The app you're trying to install isn't a Microsoft-verified app" pop-up warning appears when a user downloads and tries to install an application from somewhere other than Microsoft Store. In Windows 10, Microsoft introduced a new setting that restricts users to installing applications exclusively from Microsoft Store. To get around this limitation, you can try one of the solutions below:

Solution 1: Change Microsoft Store settings
Note, these settings may be unavailable in Windows build version below 1909.
  • Click the Start Menu button
  • Open Settings, then go to Apps
  • Where it says "Installing apps only from Windows Store helps protect your device", click the drop-down list and select "Anywhere"

Solution 2: Use command line for installing the application
  • Click Start Menu and type "cmd" in the search field
  • Right-click "Command Prompt" and choose to run it as administrator
  • Type "cd" followed by the full path to the containing folder of the app's installation package, e.g.: cd C:\Users\Username\Desktop
  • Type the name of the installation file, e.g.: setup.exe
  • Press Enter to begin the installation

Solution 3: Get out of S mode
Windows Home S mode is an increased security version of Windows Home edition, which permits applications from the Microsoft Store only. If you are using Home S and want to be able to download and install applications from somewhere else, you need to switch to the normal Home mode.
  • Click Start Menu
  • Got to Settings, then System, then About and check if your Windows version is Home or Home S
  • If it is Home S, go to Settings, then Update & Security
  • Click Go to the Store, which should open a page that says Switch Out of S Mode
  • Click the Get button, then Install
  • Once installed, go back to About and check if you have been switched from Home S to the normal Home edition

Example: go to Start - Settings - Apps - Apps & features - Installing apps, and select either Allow apps from anywhere or Turn off app recommendations (the exact words vary depending on your Windows version).

SoftPerfect support forum

Reply to this topic

Sometimes you can find a solution faster if you try the forum search, have a look at the knowledge base, or check the software user manual to see if your question has already been answered.

Our forum rules are simple:

  • Be polite.
  • Do not spam.
  • Write in English. If possible, check your spelling and grammar.

Author:

Email:

Subject

A brief and informative title for your message, approximately 4–8 words:

     

Spam prevention: please enter the following code in the input field below.

 **    **  **    **   ******   ********         ** 
 ***   **  ***   **  **    **  **     **        ** 
 ****  **  ****  **  **        **     **        ** 
 ** ** **  ** ** **  **        ********         ** 
 **  ****  **  ****  **        **         **    ** 
 **   ***  **   ***  **    **  **         **    ** 
 **    **  **    **   ******   **          ******  

Message: